file directory viewer indentation inconsistent (die, tree, die)

RESOLVED FIXED in Future

Status

()

Core
XUL
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: Nickolai Zeldovich, Assigned: Joe Hewitt (gone))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.17 i686)
BuildID:    2002013012

Files viewed using a file:// URL aren't consistently indented.
In particular, files in a subdirectory aren't always indented
and indentation changes when page is revisited.  See steps to
reproduce for more details.

Reproducible: Always
Steps to Reproduce:
1. Open, e.g., file:/// on Linux.
2. "Unfold" the bin folder by clicking the triangle next to it.
3. Observe that the files in /bin are indented one level.
4. Go back by pressing the back button, and go forward again.
5. Observe the lack of indentation for files in /bin.
seeing this with linux build 2002-01-29-21.  bbaetz, ideas?  This is the XUL
viewer, obviously.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'd be really surprised if this wasn't a <tree> bug.

-> toolkit: trees, probably to be INVALID/WONTFIX since <treE> is being replaced.
Assignee: dougt → hewitt
Component: Networking: File → XP Toolkit/Widgets: Trees
QA Contact: benc → jrgm
*** Bug 122807 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Suggest changing OS to 'All' since bug 122807 is Windows2000.

Comment 5

17 years ago
This is an age-old tree bug. There's likely a duplicate of this, but after 
looking for a while I can't find it. Fix is to swap out the old tree, which is
Real Soon Now.
OS: Linux → All
Hardware: PC → All
Summary: file indentation inconsistent → file directory viewer indentation inconsistent (die, tree, die)
Target Milestone: --- → Future

Comment 6

17 years ago
Dupe of bug 117309, which has alse been marked RESOLVED DUPLICATE.
*** Bug 123888 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
I see this is really causing havoc, I was going to file a new bug for directory
view needs outliner polish, because columns, are off by one character, and if a
filename is longer than the status bar length, the whole content of my browser
window moves on mouse over.  Hopefully that tree->outliner change will fixing
this painting problem, I've seen this problem in mail/news before, and it was
cleared up by Seth and Jan, if I recall correctly.. *dont quote me on that*

Comment 9

17 years ago
Is the change from triangle twisties -> "plus" mark threads the change from tree
-> outliner?
Well, yes, thats one of the side effects.

Comment 11

17 years ago
*** Bug 128148 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
From bug 128148, another symptom is that as you expand items, direct parents in
the line you're following lose their indentation.  For instance, expand /home,
then duvall, then bin, and notice that duvall loses its indentation.

Comment 13

17 years ago
*** Bug 130533 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 117309 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 117699 has been marked as a duplicate of this bug. ***
*** Bug 130874 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
using Mozilla 0.9.5
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011130
that comes with Komodo-1.2,
guess what ?
it works fine : this bug is not present at all.

Comment 18

17 years ago
This bug is still present under 0.9.9 on Redhat 7.2 Linux 2.4.9-31 i686
(Assignee)

Comment 19

17 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 20

17 years ago
*** Bug 136172 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.