Closed Bug 1227085 Opened 7 years ago Closed 7 years ago

Allow enabling Sync to new users, but warn about empty accounts

Categories

(Firefox OS Graveyard :: Sync, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED
2.6 S2 - 12/4

People

(Reporter: ferjm, Assigned: ferjm)

References

Details

Attachments

(1 file)

Once bug 1227084 is done, we will be technically able to create new Sync accounts. But because we are still in a read-only mode, we should warn users about empty accounts.
Blocks: fxos-sync
Priority: -- → P2
Target Milestone: --- → 2.6 S2 - 12/4
Assignee: nobody → ferjmoreno
Summary: Allow creating new Sync users, but warn about empty accounts → Allow enabling Sync to new users, but warn about empty accounts
Comment on attachment 8692102 [details] [review]
[gaia] ferjm:bug1227085.empty.sync.account > mozilla-b2g:master

Yura: Settings. Michiel: Sync. Thank you!
Attachment #8692102 - Flags: review?(yzenevich)
Attachment #8692102 - Flags: review?(mbdejong)
This patch removes the old flow where we didn't allow the user to enable Sync and we were showing a popup asking the user to go to desktop. Instead of that we now allow the user to enable Sync and we show this screen after the first sync attempt: https://gyazo.com/debb21a259efcb12b99b2c9865f6e1f7

This is a better UX cause it will help the user to not confuse the creation of a FxA with a Sync account and will make enabling Sync on any other client to eventually fix the FxOS account state (on the next synchronization which can happen manually or automatically).

This is still a temporary solution until we have read-write synchronization.
Comment on attachment 8692102 [details] [review]
[gaia] ferjm:bug1227085.empty.sync.account > mozilla-b2g:master

Settings part looks good. However I noticed one paper cut:
STR:
* Go to firefox sync panel
* Click get started (without previously logging into accounts)
* Get redirected to accounts login/creating
* Create a new account
* Press get started again
* The button gets disabled as expected, however, after a while the login page flickers with the warnings (both not activated + empty) and goes back to a logout page. I'm guessing because it take some time to get accounts to set up. However it diminishes the UX.
Attachment #8692102 - Flags: review?(yzenevich) → review+
Comment on attachment 8692102 [details] [review]
[gaia] ferjm:bug1227085.empty.sync.account > mozilla-b2g:master

Love this! Especially cool how it automatically refreshes when you verified your account from the email link.

Only minor issue I saw reported in (follow-up?) bug 1228967
Attachment #8692102 - Flags: review?(mbdejong) → review+
https://github.com/mozilla-b2g/gaia/commit/9db31513227c810e486b8e14fce44a653d0aff75
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I cannot reproduce this issue :(

(In reply to Yura Zenevich [:yzen] from comment #4)
> Comment on attachment 8692102 [details] [review]
> [gaia] ferjm:bug1227085.empty.sync.account > mozilla-b2g:master
> 
> Settings part looks good. However I noticed one paper cut:
> STR:
> * Go to firefox sync panel
> * Click get started (without previously logging into accounts)
> * Get redirected to accounts login/creating
> * Create a new account
> * Press get started again

You shouldn't be able to press get started at this point.

> * The button gets disabled as expected, however, after a while the login
> page flickers with the warnings (both not activated + empty) and goes back
> to a logout page. I'm guessing because it take some time to get accounts to
> set up. However it diminishes the UX.
You need to log in before you can comment on or make changes to this bug.