instructions how to activate safe mode wrong

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: Tonnes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1225050 +++

B2G 2.6 20151115150212 on Flame (v18D_nightly_v4 base image)

I fail to (re)start in safe mode with add-ons disabled.

Steps to reproduce (changed):
1. Open the Marketplace and install an addon.
2. Turn off the phone and turn it on again as usual.
3. Press and hold the power button - a second time.

Actual result:
The warning message is not shown and add-ons are still enabled.

Expected result:
Safe mode screen appears and add-ons are disabled.

While testing a few times in order to test the new instruction, it seems
1) A second press is needed
2) From the current message, it’s unclear when to press the button again
3) Similar, it’s unclear how long and until when to press it.

Pressing it too soon (during the bootloader) has no effect and restarts the phone, too short during the black screen has no effect, too long during the screen restarts the phone, etc. I only succeeded by pressing it 3 times for about 2 seconds each during the black screen, and I’m not sure if the new message is actually clearer than the old one.

Can the instruction message be changed to include exactly how many times, when and how long the power button should be pressed in order to avoid confusion? I’m sure developers should know the exact behavior.
You are correct that getting the timing correct can be tricky depending on the device. But you only need to long press once after bootup, until gecko starts and get the opportunity to check whether the key is pressed.

So I don't think that the instructions are wrong. Maybe we need to add some visual clue in the animation to let users know when they should press though.
(Reporter)

Comment 2

3 years ago
I was afraid this could also be device dependant allright. However, the fact that "press and hold" was replaced by "press" (while you acknowledge that a long-press is needed) made me wonder if the new message is really an improvement. I can short-press a number of times, to no avail.

For our locale, I kept the long-press part for that reason (or rather: I added "for a few seconds" to "press") and am still considering to use "during the FF OS boot screen" or similar to distinguish it from the bootloader's screen. I'll leave it up to others to reword or leave it as it is. One could say developers will be smart enough to find it anyway, but then again, that’s not a valid reason ;)

By the way, "start up" is spelled wrong, which was reported in bug 1216446 comment 36 and could have been changed along. Another reason to reword?

Comment 3

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.