What's Related sidebar panel does not work for tab-browsing

RESOLVED INVALID

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED INVALID
17 years ago
10 years ago

People

(Reporter: daniel park, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The What's Related sidebar panel does not work when you open a link or location
in a new tab.

1. Have your What's Related sidebar panel open
2. Go to any page.
3. Notice the What's Related panel is updated with relevant info.
4. Right click on a link and select "Open in New Tab"
5. Notice the What's Related panel is not updated for the document loaded in the
new tab.
tabbed browser
Assignee: sgehani → jaggernaut
Component: Sidebar → Tabbed Browser
QA Contact: sujay → sairuh

Comment 2

17 years ago
Sairuh, can you confirm this ?

Comment 3

17 years ago
oops didn't notice sairuh is the qa_contact...

Comment 4

17 years ago
Samir, does the sidebar content store a reference to _content somewhere?

Comment 5

17 years ago
Yes, in mozilla the inital hookup to _content is here: 
http://lxr.mozilla.org/seamonkey/source/xpfe/components/related/resources/related-panel.js#191>
The document load observer ignores any callbacks that aren't for the initally
hooked up content window.

Unfortunately, the commercial code diverges and also references _content using a
similar scheme to hook up a document load observer:
<http://lxr/commercial/source/xpfe/components/related/resources/related-panel.js#38>

Comment 6

17 years ago
Confirming with 2002041707 Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 132345 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Workaround for this bug:

For refreshing the "What's Related" sidebar panel left-click on any other
sidebar panel. Then left-click again on "What's related". (Tested with Build
2002051006 /Windows 98 SR 2)

PS: This is my first comment on Bugzilla. Feel free to tell me if comments like
this are useful or if I should restrain from further comments like this one. 
 
*** Bug 152555 has been marked as a duplicate of this bug. ***
QA Contact: sairuh → pmac

Updated

16 years ago
Flags: blocking1.3b+

Comment 10

16 years ago
if you don't understand how to use something, please don't use it. only drivers
are supposed to mark a bug as blocking+. if you want drivers to mark a bug as
blocking then you should mark it as blocking? and provide a strong argument
explaining why it's critical that we hold a release for a bug to be fixed.

as this bug is a year old and we've shipped a bunch of releases with it, i am
fairly certain that if you did nominate it properly it would be rejected.

the fact is that this bug is really minor, there's a workaround in the comment 8
of the bug (such comments are always welcome) and it's probably a duplicate of a
similar bug where DOM Inspector doesn't get updated for tab switches. 

i'm certain this bug is all/all, but i'm only confirming that it happens with my
windows trunk build from around the beginning of the year.
Severity: normal → minor
Flags: blocking1.3b+
OS: Linux → All
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
Assignee: jag → nobody
QA Contact: pmac → tabbed-browser

Updated

10 years ago
Depends on: 468337

Comment 11

10 years ago
This has been INVALIDated by removing the "What's related" sidebar in bug 468337.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.