Duplicate emails being sent when using firefox

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
7 months ago

People

(Reporter: fidorulz, Unassigned)

Tracking

42 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421
Firefox for Android

Steps to reproduce:

In firefox for android select and hold a link and then select share. Select gmail to send the link via gmail


Actual results:

Since about Oct 10 when sending email using Gmail but via firefox app about 50% of time email is sent 2 times.

Email is shown in sent items 2 times and is received 2 times.

Gmail was removed and uninstalled and reinstalled as well as firefox and issue remains

Issue is on wifi or LTE or 3G and with mutiple devices

One thing I noticed is when issue occurs gmail(via PC) shows the following in the details

for first of the duplicate email

mailed-by:    gmail.com
signed-by:gmail.com

for the 2nd email in the pair it only shows mailed-by:    gmail.com

Im using 5.1.1 on a Samsung Note 3 N900W8 and Samsung Tab 4 SM-T530

If sending email via gmail app directly or any other apps are used to email via gmail there is no issue

Firefox version-42.0.1
Gmail version-5.8.107203005


Expected results:

email should have been sent only once
(Reporter)

Updated

3 years ago
OS: Unspecified → Android
Hardware: Unspecified → ARM
Component: Untriaged → General
Product: Firefox → Firefox for Android
Version: 42 Branch → Firefox 42

Comment 1

7 months ago
Hi, thanks for report. I tried with Nexus 6P (Android 8.1.0) and and OnePlus 5T	(Android 8.0.0) on latest Nightly and I can't reproduce your issue. Can you retry on latest nightly and see if the issue it's still reproducible?

Updated

7 months ago
Flags: needinfo?(fidorulz)
(Reporter)

Comment 2

7 months ago
To my knowledge the issue is no longer occurring.

Thank you
Flags: needinfo?(fidorulz)

Updated

7 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.