Closed Bug 1227295 Opened 6 years ago Closed 6 years ago

Unable to modify password after entering an incorrect password for a WiFi network

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5?
Tracking Status
b2g-v2.2 --- unaffected
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: KTucker, Assigned: hchang)

References

()

Details

(Keywords: regression, Whiteboard: [2.6-Daily-Testing][Spark][dogfood-blocker])

Attachments

(3 files)

If the user enters an incorrect password for a wireless network, they will notice that they cannot correct the password by re-tapping on the wireless network. 

Repro Steps:
1) Update a Flame to 20151120180302
2) Open settings. 
3) Open "Wi-Fi".
4) Tap on an available WiFi network, put in the incorrect password and tap "OK".

Notice the phone will try to connect to that wireless network several times.

5) Tap on the wireless network again and try to correct the password. 

Please note that if you are having trouble reproducing this issue choose a different wireless network, put in the incorrect password and then try to reopen both of the wireless networks again. 

Actual:
The user cannot correct an incorrect password that they entered for a wireless network. 

Expected:
The user can connect to the wireless network again and enter the correct password. 

Environmental Variables:
Device: Flame 2.6 (Full Flash)(KK)(512mb)
Build ID: 20151120180302
Gaia: c41da60c52fa2563ae90fbd71b755591c6d288d5
Gecko: 52286f207187af544d7c842e0c193e47881845d3
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 5/5, 100%
See attached: video clip, logcat
Whiteboard: [2.6-Daily-Testing][Spark]
This issue also occurs on Aries 2.6, Flame 2.6 and Aries 2.5 

The user cannot re-enter the wireless network to fix the password or forget it after entering an incorrect password.

Device: Aries 2.6
BuildID: 20151123143009
Gaia: bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Gecko: d3d286102ba7f8801e9dfe12d534f49554ba50c0
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.6 [Full Flash][512mb]
BuildID: 20151123142444
Gaia: bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Gecko: d3d286102ba7f8801e9dfe12d534f49554ba50c0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Aries 2.5
BuildID: 20151123164502
Gaia: 5839f17dedc757947c9531dc0d66c3c49119f5ea
Gecko: 3a45ca93dd447e046baa2c7590f60ae008e438f8
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

-----------------

This issue does not occur on Flame 2.2

The user can always tap on the wireless network again and tap "Forget" to re-enter a password. 

Device: Flame 2.2 (Full Flash)(KK)(512mb)
BuildID: 20151120032503
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 462d8e9208ea
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Please note the easiest way to reproduce this issue is:

1. Factory reset the device.
2. Enter an incorrect password for a wireless network in the FTU.
3. Complete the FTU and open settings.
4. Open WiFi connections and tap on the wireless network connection again that was selected in step 2. 

Actual:
The user cannot re-enter the password or forget the connection.
QA Contact: jthomas
[Blocking Requested - why for this release]:

This could lead to end user frustration.
blocking-b2g: --- → 2.5?
Caused by changes made in Bug 1144623

B2G Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150923004736
Gaia: 1ce80ea9e5e08df05b1470e33309e7f112b2f37e
Gecko: 1215959465252fd75bfbd4102d0559a2de9a6cb1
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150923010836
Gaia: 562d347110012016951eec4e3808f4e85acd5ca7
Gecko: b806a3c75f5865fa5ae2e4829fd43c42512e890b
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working gaia / First Broken gecko - This issue does NOT occur with broken Gecko
Gaia: 1ce80ea9e5e08df05b1470e33309e7f112b2f37e
Gecko: b806a3c75f5865fa5ae2e4829fd43c42512e890b

Last Working gecko / First Broken gaia - This issue DOES occur with broken Gaia
Gecko: 1215959465252fd75bfbd4102d0559a2de9a6cb1
Gaia: 562d347110012016951eec4e3808f4e85acd5ca7

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/1ce80ea9e5e08df05b1470e33309e7f112b2f37e...562d347110012016951eec4e3808f4e85acd5ca7
Blocks: 1144623
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Henry and Fred the changes for bug 1144623 seem to have caused this issue.  Can you please take a look
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Flags: needinfo?(hchang)
Flags: needinfo?(gasolin)
Ken, can you get someone to look at this please?  This is an urgent issue and needs to be resolved before Orlando as we're trying to get a stable dogfood build for the next batch of releases.
Flags: needinfo?(kchang)
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][dogfood-blocker]
Assignee: nobody → hchang
Flags: needinfo?(hchang)
I will be looking into this issue
According to comment6.
Flags: needinfo?(kchang)
Not found any clue that why bug 1144623 would cause this issue. 

Regarding "cannot forget network", I found when you click "Forget Network" and hit "Confirm", the network is actually forgotten by gonk. The thing is when you click the network to try to associate again, gaia would just pass "*" to MozWifiManager.associate web API. Still be investigating.
Just found the root cause that why we are not able to forget network and I believe it's a long standing issue.

STR:

1) Enter wrong password.
2) The first connecting would fail.
3) Before the retry starts, go to "Manage Networks"
4) Forget the network that we just failed to connect
5) Back to wifi network list and connect to the same network again
6) No dialog prompt (supposed to pop a dialog to ask prompt you the password)

When you hit this issue, request a new scan would fix it. 

+ First try
+ Failed
+ 
+ Idle        (if you do scan at this point, the password of the network would be '*')
+
+ Second try
+
+ Idle
+
+ ...

The reason is, when you failed to connect to a network and are waiting for retry, chances are the network list gets updated and password is set to '*'. The use of '*' is just a mark to prevent asking password if the network has been connected successfully. 

After we forget a network, a new scan seems not to be triggered so '*' is sent to MozWifiManager.associate.

The solution might be:

1) Force trigger a new scan after we forget a network
2) Clean password from network in wifi_network_list. (this is what "onfailingconnect") handler does.
Comment on attachment 8693441 [details] [review]
[gaia] elefant:Bug1227295-unable-forget-wifi-pw > mozilla-b2g:master

Hi Fred,

Could you give me some feedback regarding the patch that I discussed with offline? I am writing the test and will send a new PR afterward. Thanks!
Attachment #8693441 - Flags: feedback?(gasolin)
Comment on attachment 8693441 [details] [review]
[gaia] elefant:Bug1227295-unable-forget-wifi-pw > mozilla-b2g:master

overall looks good, please address comments on github
Flags: needinfo?(gasolin)
Attachment #8693441 - Flags: feedback?(gasolin) → feedback+
Naoki,

As Henry's comment 9 its a long stand issue. And the work around is press the `search network` button again.

Therefore I think it should not block the foxfooding release.
Flags: needinfo?(nhirata.bugzilla)
(In reply to Fred Lin [:gasolin] from comment #13)
> Naoki,
> 
> As Henry's comment 9 its a long stand issue. And the work around is press
> the `search network` button again.
> 
> Therefore I think it should not block the foxfooding release.

That said, I have a patch to fix this issue and am fixing the test case issue. Should be landed soon.
Comment on attachment 8693441 [details] [review]
[gaia] elefant:Bug1227295-unable-forget-wifi-pw > mozilla-b2g:master

Hi Fred, 

The latest PR passed all the test cases so I am asking for review for the patch. Thanks :)
Attachment #8693441 - Flags: review?(gasolin)
Comment on attachment 8693441 [details] [review]
[gaia] elefant:Bug1227295-unable-forget-wifi-pw > mozilla-b2g:master

Code looks good to me, please make sure test on device before landing
Attachment #8693441 - Flags: review?(gasolin) → review+
(In reply to Fred Lin [:gasolin] from comment #16)
> Comment on attachment 8693441 [details] [review]
> [gaia] elefant:Bug1227295-unable-forget-wifi-pw > mozilla-b2g:master
> 
> Code looks good to me, please make sure test on device before landing

Testing perfectly from my side! Thanks!
Keywords: checkin-needed
Since the patch is already there, I'm cutting a build with the patch for T2M base build.

For Orlando, this bug will be in the RC1.  We're going to try having an RC2 that would include the patch in here if this lands and sync.  Please land this before 3 am pdt.
Flags: needinfo?(nhirata.bugzilla)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
This issue is verified fixed in Flame 2.6 and Aries 2.6.

Environmental Variables:
Device: Aries 2.6 [Full Flash]
BuildID: 20151203121905
OTAID: 20151203120657
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: FlameKK 2.6 [Full Flash][512mb]
BuildID: 20151203053521
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
User is able to re-enter the password after the wi-fi attempts to connect a few times.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jmercado)
Fred this was blocking 2.5, what needs to be done for it to be uplifted there?

Setting verifyme to check 2.5 whenever it is uplifted.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(gasolin)
Keywords: verifyme
Comment on attachment 8693441 [details] [review]
[gaia] elefant:Bug1227295-unable-forget-wifi-pw > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): long standing issue
[User impact] if declined: can't disconnect until user tap search button again
[Testing completed]: verified
[Risk to taking this patch] (and alternatives if risky): if there's any unawared issue
[String changes made]: None
Flags: needinfo?(gasolin)
Attachment #8693441 - Flags: approval-gaia-v2.5?
Comment on attachment 8693441 [details] [review]
[gaia] elefant:Bug1227295-unable-forget-wifi-pw > mozilla-b2g:master

Approved for 2.5. High possibility of entering a wrong password on TV. 

Please uplift this. Thanks
Attachment #8693441 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Need check in to 2.5
Keywords: checkin-needed
This bug has been verified as "pass" on the latest build of Aries KK v2.5 and Flame KK v2.5 512mb by the STR in comment 0.

Actual results: The user can connect to the wireless network again and enter the correct password.

See attachment: Verified_Aries_v2.5.3gp
Reproduce rate: 0/10

Device: Aries KK v2.5(Pass)
Build ID               20151214084334
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151214.074854
Firmware Date          Mon Dec 14 07:49:02 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 512mb(Pass)
Build ID               20151214083757
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d76a9f65b6ba2ab587d3a0fb5119773ba68720a0
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151214.074606
Firmware Date          Mon Dec 14 07:46:17 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.