communitybox and topicboxes macros producing invalid code

RESOLVED FIXED

Status

Developer Documentation
Macros/Templates
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: shobson, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
For some reason the communitybox and topicboxes macros are producing a list of items where the first child is a <a> instead of a <li>. The problem is more likely to be in the DiscussionList template but I had a look and could not figure out what's going on :(

Example of invalid code:
<ul class="communitymailinglist">
  <a href="https://lists.mozilla.org/listinfo/dev-mdc" class="external external-icon">Mailing list</a> 
  <li><a href="http://groups.google.com/group/mozilla.dev.mdc" class="external external-icon">Google Group</a></li> 
  <li><a href="http://groups.google.com/group/mozilla.dev.mdc/feeds" class="external external-icon">RSS feed</a></li> 
</ul>

Test page:
https://developer.mozilla.org/en-US/docs/User%3Astephaniehobson%3Acommunitybox

This bug is visible because the space between the <a> has less space between it and all the <li>s.

Comment 1

2 years ago
Fixed this in https://developer.mozilla.org/en-US/docs/Template:DiscussionList (used by both of the other templates), where the "<ul" tag was not getting a closing ">", and was therefore stealing it from the first "<li>".
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

2 years ago
Awesome, thanks :)
You need to log in before you can comment on or make changes to this bug.