Update b2g_branch_repos.py script and config to handle b2g b2g-ota branching

RESOLVED FIXED

Status

Release Engineering
Release Requests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: hwine, Assigned: hwine)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-ota])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1203187 +++

For v2.5, the branch script needed adjustment (see bug 1203187 comment 0). Do proactively this time.
(Assignee)

Updated

3 years ago
Blocks: 1227346
(Assignee)

Updated

3 years ago
Whiteboard: [b2g-ota]
(Assignee)

Updated

3 years ago
Blocks: 1227349
(Assignee)

Updated

3 years ago
No longer blocks: 1227349
(Assignee)

Comment 1

3 years ago
For b2g-ota, we appear to have some additional work similar that needed for v2.5:

$ time ./b2g_branch_repos.py -c ../../configs/merge_day/b2g_branch_repos.py --branch-name b2g-ota --no-push11:59:47     INFO - MultiFileLogger online at 20151125 11:59:47 in /Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day
11:59:47     INFO - Run as ./b2g_branch_repos.py -c ../../configs/merge_day/b2g_branch_repos.py --branch-name b2g-ota --no-push
... (850 lines of success) ...
12:00:11     INFO -                                          '/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/sony-aosp-l.xml']},
12:00:11     INFO -           'fetch': u'git://github.com/mozilla-b2g/vex',
12:00:11     INFO -           'revision': u'fxos'}}
12:00:11    FATAL - Sanity: Not clear where to branch for platform_build git://github.com/mozilla-b2g/platform_build {u'b2g-4.4.2_r1': ['/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/emulator-kk.xml'],
12:00:11    FATAL -  u'b2g-5.1.0_r1': ['/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/emulator-l.xml'],
12:00:11    FATAL -  u'master': ['/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/emulator.xml',
12:00:11    FATAL -              '/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/tarako.xml']}
12:00:11    FATAL - Sanity: Not clear where to branch for device_lge_hammerhead-kernel git://github.com/mozilla-b2g/device_lge_hammerhead-kernel {u'b2g-4.4.2_r1': ['/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/nexus-5.xml'],
12:00:11    FATAL -  u'b2g-5.1.0_r1': ['/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/nexus-5-l.xml']}
12:00:11    FATAL - Sanity: Not clear where to branch for device-hammerhead git://github.com/mozilla-b2g/device-hammerhead {u'b2g-4.4.2_r1': ['/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/nexus-5.xml'],
12:00:11    FATAL -  u'b2g-5.1.0_r1': ['/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/nexus-5-l.xml']}
12:00:11    FATAL - Sanity: Not clear where to branch for platform_bionic git://github.com/mozilla-b2g/platform_bionic {u'b2g-4.0.4_r2.1': ['/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/emulator.xml'],
12:00:11    FATAL -  u'b2g-4.4.2_r1': ['/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/emulator-kk.xml',
12:00:11    FATAL -                    '/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/flame-kk.xml',
12:00:11    FATAL -                    '/Users/hwine/repos/mozilla-central/testing/mozharness/scripts/merge_day/build/b2g-manifest/shinano.xml']}
12:00:11    FATAL - Use --branch-order or self.config['no_branch_repos'] to fix!
12:00:11    FATAL - Running post_fatal callback...
12:00:11    FATAL - Exiting -1

real    0m23.649s
user    0m14.456s
sys     0m2.367s
255 [hwine@hwin-28520 merge_day]
$
(Assignee)

Comment 2

3 years ago
Created attachment 8692265 [details] [diff] [review]
additional no-branch repos

Okay, following reverse-engineered process from bug 1203187:
- from comment 1 run, get problem repo names via:
  grep -w CRITICAL logs/b2g_branch_repos_critical.log | cut -d\  -f5 | sort -u
- add those repos to the config file "no_branch_repos" list
Assignee: nobody → hwine
Status: NEW → ASSIGNED
(Assignee)

Comment 3

3 years ago
The decision on whether or not to branch all the subsidiary repos is one that need not be finalized until real builds are produced.
Assignee: hwine → nobody
No longer blocks: 1227346
Status: ASSIGNED → NEW
(Assignee)

Updated

3 years ago
Blocks: 1229392
(Assignee)

Comment 4

3 years ago
per bug 1227346 comment #3, we want all the same as on master currently
(Assignee)

Comment 5

3 years ago
Did run using this patch locally. Now needs to be committed.
Assignee: nobody → hwine
Status: NEW → ASSIGNED
(Assignee)

Comment 6

3 years ago
Comment on attachment 8692265 [details] [diff] [review]
additional no-branch repos

Checking needed - NPOTB
Attachment #8692265 - Flags: review+
Attachment #8692265 - Flags: checked-in?

Updated

3 years ago
Attachment #8692265 - Flags: checked-in? → checked-in+
(Assignee)

Comment 8

3 years ago
and done \o/
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1230278
You need to log in before you can comment on or make changes to this bug.