Date picker carousel is overlapping the SIM PIN screen

VERIFIED DUPLICATE of bug 1224128

Status

VERIFIED DUPLICATE of bug 1224128
3 years ago
3 years ago

People

(Reporter: KTucker, Assigned: timdream)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.2 unaffected, b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark], URL)

Attachments

(2 attachments)

Created attachment 8691127 [details]
logcat_20151123_1640.txt

Locking and unlocking the phone on the date picker carousel causes the SIM PIN screen to be overlapping each other.

Prequisite:
SIM PIN and lockscreen are enabled. 

Repro Steps:
1) Update a Aries to 20151123143009
2) Off a fresh flash or factory reset, go through the FTU but be sure to skip the SIM PIN screen when prompted. 
3) Open "Settings". 
4) Tap on "Date and Time".
5) Click on the date dropdown to change the date.
6) While on the date picker carousel, lock and unlock the device.
7) Observe the date picker carousel screen.

Actual:
The date picker carousel and the SIM PIN screen do not overlap each other.

Expected:
The user is prompted to enter a SIM PIN first and then they are taken to the date picker carousel.

Environmental Variables:
Device: Aries 2.6
BuildID: 20151123143009
Gaia: bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Gecko: d3d286102ba7f8801e9dfe12d534f49554ba50c0
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 5/5, 100%
See attached: video clip, logcat
This issue also occurs on Flame 2.6

The date picker carousel and SIM PIN screens are overlapping.

Device: Flame 2.6 [Full Flash][512mb][KK]
BuildID: 20151123142444
Gaia: bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Gecko: d3d286102ba7f8801e9dfe12d534f49554ba50c0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

------------------

This issue does not occur on Aries 2.5 and Flame 2.2

The SIM PIN is prompted first and then the user is taken to the date picker carousel.

Device: Aries 2.5
BuildID: 20151123164502
Gaia: 5839f17dedc757947c9531dc0d66c3c49119f5ea
Gecko: 3a45ca93dd447e046baa2c7590f60ae008e438f8
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.2 (Full Flash)(KK)(512mb)
BuildID: 20151120032503
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 462d8e9208ea
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-v2.5: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: regression
Whiteboard: [2.6-Daily-Testing][Spark]
This is a bit of an edge case, but the experience is really bad so nominating to block.  Iris can I get your thoughts as well?

Let's get a window here regardless.
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado) → needinfo?(ihsiao)
Keywords: regressionwindow-wanted
Created attachment 8691250 [details]
2015-11-23-20-43-36.png

I can recreate the issue on aries, and I also found this issue would happen in "City" picker (Settings > Date and Time> Time Zone area > City, please see the attached screen shot.
However, I can't reproduce it every time. 
I agree that this is an edge case, and I think it is a lower priority issue for users.
Flags: needinfo?(ihsiao)
QA Contact: jthomas
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]
Caused by changes made in Bug 1207485 

B2G Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20151019000932
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: 7aa88c466932c343fa40f12afb1bac82d9bd7385
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20151019010933
Gaia: 043b7c9231335e2257588005ab9c13dcdb7fc3c4
Gecko: ee9f3c9bb56c9135af0263b65eb4312604bfa772
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working gaia / First Broken gecko - This issue does NOT occur with broken Gecko
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: ee9f3c9bb56c9135af0263b65eb4312604bfa772

Last Working gecko / First Broken gaia - This issue DOES occur with broken Gaia
Gecko: 7aa88c466932c343fa40f12afb1bac82d9bd7385
Gaia: 043b7c9231335e2257588005ab9c13dcdb7fc3c4

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/f75bd584aca0a751a5bed115800250faa8412927...043b7c9231335e2257588005ab9c13dcdb7fc3c4
Blocks: 1207485
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Tim this issue seems to have been caused by the changes for bug 1207485.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(timdream)
This should definitely block. Thanks.
Assignee: nobody → timdream
blocking-b2g: 2.6? → 2.6+
Flags: needinfo?(timdream)
Whiteboard: [2.6-Daily-Testing][Spark][systemsfe] → [2.6-Daily-Testing][Spark]
I can confirm this is caused by the same issue described in bug 1224128 too....
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224128
According to https://bugzilla.mozilla.org/show_bug.cgi?id=1224128#c11, I change the status to "resolved verified".
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.