Closed Bug 1227378 Opened 4 years ago Closed 2 years ago

Drag and dropping images causes freeze in browser

Categories

(Core :: Plug-ins, defect, major)

42 Branch
x86_64
Windows 10
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: cloudwomega, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

Take an image and drop it onto the desktop(amount varies but is within the single digits)


Actual results:

the browser freezes fully. A popup shows telling me that shock-wave flash has become unresponsive. even with no instance of flash running.

I can click "stop script" but it will just remain in an endless loop with the popup continuing to appear.

instead i had to force kill the browser.


Expected results:

nothing, it should have just let me continue my browsing.
Severity: normal → major
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151125030231

Works fine for me using the latest Nightly on Windows 10.

Reporter, could you please let me know if you are still seeing the issue when:
- starting Firefox in safe mode
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
- starting Firefox with a new profile
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
- starting Firefox after a reset 
https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems
Tried them all already, does it even when in safe mode.
Please post you Graphic section from about:support
Graphics
Adapter Description	AMD Radeon R9 200 Series
Adapter Drivers	aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	4095
Asynchronous Pan/Zoom	none
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
Device ID	0x67b1
Direct2D Enabled	true
DirectWrite Enabled	true (10.0.10586.0)
Driver Date	11-17-2015
Driver Version	15.300.1025.0
GPU #2 Active	false
GPU Accelerated Windows	9/9 Direct3D 11 (OMTC)
Subsys ID	30811462
Supports Hardware H264 Decoding	false
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon R9 200 Series Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
(#0) Error	Too many dropped/corrupted frames, disabling DXVA






to note, this happened only after the 42 update, ive even reinstalled flash fully and  changed drivers for my gpu to the newest ones since it started, so it can be pinned on the browser update causing it somehow
Blocks: windows-10
I still can't reproduce this on the latest Nightly or Firefox 42 - tested with and without an enabled Flash plugin.
Component: Untriaged → Plug-ins
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.