Closed Bug 1227415 Opened 6 years ago Closed 6 years ago

Decoded video size becomes a bit smaller during seeking video on nexus-5-l and aries

Categories

(Core :: Audio/Video: Playback, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla45
Tracking Status
firefox45 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

(Whiteboard: [backout-asap])

Attachments

(1 file)

Decoded video size becomes a bit smaller during seeking the following video on nexus-5-l.
  http://people.mozilla.org/~cpeterson/videos/H264_Baseline_Profile_Level_30_640x360p.mp4
It seems regression of bug 1199809.
Assignee: nobody → sotaro.ikeda.g
Blocks: 1199809
Priority: -- → P2
Hardware: Unspecified → ARM
When the problem happens, there are difference between encoded video size and display video size.

H264_Baseline_Profile_Level_30_640x360p.mp4: display size(640, 360), encoded size(640, 368).
The problem happen also on flame-kk and aries(kk).
Summary: Decoded video size becomes a bit smaller during seeking video on nexus-5-l → Decoded video size becomes a bit smaller during seeking video on gonk
(In reply to Sotaro Ikeda [:sotaro] from comment #3)
> The problem happen also on flame-kk and aries(kk).

Sorry, the problem does not happen on flame-kk.

The problem happens on nexus-5-l and aries.
Summary: Decoded video size becomes a bit smaller during seeking video on gonk → Decoded video size becomes a bit smaller during seeking video on nexus-5-l and aries
(In reply to Sotaro Ikeda [:sotaro] from comment #2)
> When the problem happens, there are difference between encoded video size
> and display video size.
> 
> H264_Baseline_Profile_Level_30_640x360p.mp4: display size(640, 360), decoded size(640, 368).

On flame-kk, display size(640, 360) and decoded size(640, 360). Both are equal size and there is not problem of crop rect.
The patch fixed the video rendering size during seeking. But there is still video size difference. The remaining problem seems to be caused by EGL_ANDROID_image_crop. Crop setting in EGLImageCreateFromNativeBuffer() seems not work correctly. It might be a POVD problem.
Depends on: 1227452
Attachment #8691306 - Flags: review?(jolin)
Comment on attachment 8691306 [details] [diff] [review]
patch - Fix copy buffer size

Review of attachment 8691306 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. And thanks for removing the unused parameter! :)
Attachment #8691306 - Flags: review?(jolin) → review+
https://hg.mozilla.org/mozilla-central/rev/e1372ddbf94d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
This landing for this issue has caused the smoketest blocking bug 1230258.
Whiteboard: [backout-asap]
You need to log in before you can comment on or make changes to this bug.