Firefox not load properly forum http://starwars.ea.com/starwars/battlefront/forums

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: mkdante381, Unassigned)

Tracking

({qawanted, testcase-wanted})

43 Branch
x86_64
Windows 7
qawanted, testcase-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151123113812

Steps to reproduce:

Firefox not load properly star wars ea forum http://starwars.ea.com/starwars/battlefront/forums

Go to http://starwars.ea.com/starwars/battlefront/forums
Problem with reply on forum and page looks different compared to Google Chrome.
Page on Google Chrome: http://i.imgur.com/7v5y9lF.png?1
Page on Firefox: http://i.imgur.com/HDEHJ9T.png?1


Actual results:

http://starwars.ea.com/starwars/battlefront/forums look different compared to Google Chrome
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151126030226

Indeed, the text looks slightly different. 
Perhaps there's someone with extensive knowledge on this area that might be able to help here.
Component: Untriaged → Layout: Text
Product: Firefox → Core
What is the difference you're having a problem with, exactly?

1)  The two screenshots have different window widths.  Pages having slightly different layout at different widths is obviously expected.

2)  The screenshots are not actually of http://starwars.ea.com/starwars/battlefront/forums but of some other URL, perhaps <http://starwars.ea.com/starwars/battlefront/forums/discussion/comment/52722%23Comment_52722>.
Flags: needinfo?(mkdante381)
(Reporter)

Comment 3

2 years ago
FF loads this site in the another way. Firefox not load this black avatar(this is my partner for game) on the right corner, my avatar. On Google Chrome "Categories" default is clicked, on FF I must click in " +"categories. Sometime FF not load properly "reply" section
Flags: needinfo?(mkdante381)
> Firefox not load this black avatar(this is my partner for game) on the right corner, my
> avatar.

At the same window size?  Note that the site uses media queries to present different layouts at different window sizes.

Is there a way to reproduce this avatar bit that does not require having an account on the site in question?

> On Google Chrome "Categories" default is clicked, on FF I must click in " +"categories.

This part I can reproduce.  It looks like the site is trying to synthesize clicks on this stuff during load and it doesn't work the same way in Firefox and Chrome.  I can't tell whether that's a bug on our end or on the site's end so far; a smaller testcase would be really helpful there...
Keywords: qawanted, testcase-wanted
(Reporter)

Comment 5

2 years ago
1. FF not load black avatar(look on Google Chrome screenshot, at the top, next to my avatar). This black avatar is actual partner in game(coop mission or multiplayer) and is always on right side, beside normal avatar, at the top site. 
2. Firefox not load properly Reply section. Check this on google chrome and Firefox.
(In reply to Boris Zbarsky [:bz] from comment #4)
> > On Google Chrome "Categories" default is clicked, on FF I must click in " +"categories.
> 
> This part I can reproduce.  It looks like the site is trying to synthesize
> clicks on this stuff during load and it doesn't work the same way in Firefox
> and Chrome.  I can't tell whether that's a bug on our end or on the site's
> end so far; a smaller testcase would be really helpful there...

I can't reproduce this part. For me, the "Categories" field is in the same state on the latest Nightly 45.a1, Firefox 43 and Chrome.
(Reporter)

Comment 7

2 years ago
Now is all OK. Site load properly
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.