Twisty collapses (erroneously) while the thread is still expanded

RESOLVED DUPLICATE of bug 123858

Status

()

Core
XUL
P3
major
RESOLVED DUPLICATE of bug 123858
16 years ago
10 years ago

People

(Reporter: Håkan Waara, Assigned: janv)

Tracking

({regression})

Trunk
mozilla1.0.1
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Sometimes when I browse news threads, or read my email threaded, some threads
'forget' about their children... meaning that even though the container/twisty
is collapsed, there are children displayed (and the thread-lines are drawn).

It seems as if the container/twisty state gets messed up somehow. I encounter
this quite often nowadays - and I don't know what causes it, but it's really
annoying.
(Reporter)

Comment 1

16 years ago
CC hyatt in case he has seen this, or know the problem.
(Reporter)

Comment 2

16 years ago
Created attachment 67240 [details]
Step 1

Step 1: see the broken thread in the middle of the screenshot.
(Reporter)

Comment 3

16 years ago
Created attachment 67241 [details]
Step 2

Step 2: this is how it looks like when I click the twisty. If I click it again,
one duplicate will disappear, and we go back to a state where it looks like in
"Step 1".
(Reporter)

Updated

16 years ago
Keywords: mozilla0.9.9, regression

Comment 4

16 years ago
-> jan
Assignee: hewitt → varga
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 5

16 years ago
I can reproduce this now all the time.  For a mailing list I participate in,
when I click on a thread with *only* new messages, the thread twisty collapses
when I read the first message in the thread - the message that started thread.

Sorry for such a fuzzy explanation, but this is the best I can do. :-)
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1
(Reporter)

Comment 6

16 years ago
Still happening very often in RC1.

When I select the "main" message of an expanded thread (i.e. the one with the
twisty beside it), the twisty will often collapse -- but the thread is still
expanded -- and the twisty shouldn't have been collapsed in the first place.

Hope this clarifies this bug a bit.
(Reporter)

Updated

16 years ago
Summary: Sometimes outliner threads 'forget' about a child → Twisty collapses (erroneously) while the thread is still expanded
(Reporter)

Comment 7

16 years ago
More info:  it happens often when browsing newsgroup threads in mailnews. It
happens both on Linux and Windows.
(Assignee)

Comment 8

16 years ago
nominating
Keywords: nsbeta1

Comment 9

16 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
(Assignee)

Comment 10

16 years ago
hwaara, look at bug 123858
(Reporter)

Comment 11

16 years ago
Sounds like a dup.

*** This bug has been marked as a duplicate of 123858 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.