Printer name in Japanese is displayed as garbage in Print dialog

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
P2
normal
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Koike Kazuhiko, Assigned: rods (gone))

Tracking

({intl})

Trunk
mozilla1.0
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Printer name in Japanese is displayed as garbage in Print dialog.

Build: 2002013003/WinXP

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 1

16 years ago
Could you please kindly attach a screen shot?  Thanks!  cause I don't have any
network printer which was named in Japanese. 

Comment 2

16 years ago
Created attachment 67426 [details]
Mozilla print dialog (Bad)

BuildID: 2002013103
OS:WinXP

Comment 3

16 years ago
Created attachment 67427 [details]
native dialog print dialog (good)

Build ID: 2002013103
OS:Windows XP

Comment 4

16 years ago
I attached two dialog screen shots.

When printer name is displayed as garbage, I can't also open print-properties.

When I use native print dialog(Edit-Preferences-Debug-Use Native Print Dialog),
print dialog isn't displayed as garbage, and I can open Print Properties. 

Comment 5

16 years ago
See bug 122514 for the Print dialog UI problem, I think they are caused by same
reason - We used had the native UI by default before, so I haven't had this
problem before. 

I'm not quite sure if we'll include this English print dialog by the time when
we ship, if we do, the only problem is will have the problem in this bug report.

Comment 6

16 years ago
Reporter:
Could you please check this on latast build? seems there are some changes
recently.  Thanks!

Comment 7

16 years ago
It is not displayed correctly yet.
It is the same result as attachment 67426 [details]

BuildID: 2002021203
OS: Windows XP(japanese)

Comment 8

16 years ago
Hmm, on 02-12 netscape trunk build, the default setting for printer in
preferences is "use native print dialog" that's why I don't see it.

So the bug is existing when printer option in preferences is "use global print
settings".

Comment 9

16 years ago
I mistook Mozilla pint dialog was modified.
sorry.

When I run moziila by new profile, 
I confirmed checking in 'Use Native Print Dialog' by the default.

Printer which was named in Japanese was correctly displayed.

Thanks!

OS:Windows XP(Japanese)
Build ID: 2002021303

Comment 10

16 years ago
give this to rods.
rods- please point out where are the code (file, lines, function) which you got
such string from the OS. we probably can help you to figure out how to change it.

nhotta, please help rods.
Assignee: yokoyama → rods
Component: Internationalization → Printing
Keywords: nsbeta1
Priority: -- → P2
Marking nsbeta1+. 
Keywords: nsbeta1 → nsbeta1+
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 12

16 years ago
The native print dialog should be used as default now, so this should be fixed.
marking works for me.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
The default is setting to native print, and there is no debug option for
non-native print dialog in preferences now.

So, this problem won't not show in our product, mark it as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.