Task Manager sometimes pans over and opens the wrong app when tapping an App Card.

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: kats)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark][systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8691648 [details]
logcat_task-manager.txt

Description:
When the user has several apps open, if the user pans left or right and taps an app, Task Manager will pan back to the previously open app and reopen it.

Notes:
-This seems to occur more frequently when only two apps are in the Task Manager, but will occur with any number of apps.
-This issue also seems to occur more frequently on Flame devices (5/10 times) than Aries devices (2/10 times).
-If the user taps an app on the side of the screen without first panning over to it, the correct app seems to open every time.

Repro Steps:
1) Update an Aries to 20151124121635
2) Launch two apps (Gallery and Messages)
3) Long press the Home button to enter Task Manager
4) Pan over to the other app and tap the app card
5) Repeat steps 3-4 several times.

Actual:
The task manager will sometimes pan back to the previous app and reopen the wrong app.

Expected:
The task manager will always open the app selected by the user.

Environmental Variables:
Device: Aries 2.6
Build ID: 20151124121635
Gaia: e63c07af8cc636b9ffac2c20f9b8ad7e7fe2b977
Gecko: 45273bbed8efaface6f5ec56d984cb9faf4fbb6a
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 4/10
See attached: Video, Logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the latest Flame 2.6 OTA build.
The task manager will sometimes pan back to the previous app and reopen the wrong app.

Environmental Variables:
Device: Flame 2.6
BuildID: 20151124120818
Gaia: e63c07af8cc636b9ffac2c20f9b8ad7e7fe2b977
Gecko: 45273bbed8efaface6f5ec56d984cb9faf4fbb6a
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

*********************************

This issue does NOT occur on the latest Flame 2.5 OTA build.
The task manager will always open the app selected by the user.

Environmental Variables:
Device: Flame 2.5
BuildID: 20151124190915
Gaia: 7726bfd621d709fa2d179704a44aebc1c309c296
Gecko: 124375497b14260515e8d2af9c8507a9995b7a47
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Tried this multiple times but could not get this to reproduce. Adding steps-wanted.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: steps-wanted
I can reproduce this. I think you have to swipe a certain way over the card for this to reproduce.

STR:
1) Open two apps (I tested with Phone and Messages app)
2) Bring up card view
3) Swipe quickly, with force, over the screen from center to right

- sometimes you'll observe the card seems to move a little funny. Like it tries to bounce back from right to left but doesn't. If you see this, the bug is likely to repro. But I've also seen it repro without seeing this happen.

4) Tap on the card in the center

Repro rate: 4/10 on both Flame and Aries

Confirmed that 2.5 is unaffected.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: steps-wanted
Let's attempt to get a window here, but if the repro rate drops further please stop.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
QA Contact: pcheng
mozilla-inbound regression window:

Last Working
Device: Flame
BuildID: 20151117210800
Gaia: 28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gecko: ccb27d336e71839d10d08f9bd850da4c7da382c7
Version: 45.0a1 (2.6 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Device: Flame
BuildID: 20151118055622
Gaia: cba7e4b86361af31b153cfebaf99900e0b860f7b
Gecko: 8adfc688229848672e0ce4b996280770fef26d57
Version: 45.0a1 (2.6 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Last Working Gaia First Broken Gecko - repro
Gaia: 28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gecko: 8adfc688229848672e0ce4b996280770fef26d57

Last Working Gecko First Broken Gaia - no repro
Gaia: cba7e4b86361af31b153cfebaf99900e0b860f7b
Gecko: ccb27d336e71839d10d08f9bd850da4c7da382c7

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ccb27d336e71839d10d08f9bd850da4c7da382c7&tochange=8adfc688229848672e0ce4b996280770fef26d57

This issue is possibly caused by changes made in Bug 1222524.
Blocks: 1222524
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Chirs this issue seems to have been caused by the changes for bug 1222524.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(chrislord.net)

Comment 7

3 years ago
Discussing this in bug 1227789. Assigning to me for now so we don't lose track of it, but I may not have time to deal with this before PTO.
Assignee: nobody → chrislord.net
Flags: needinfo?(chrislord.net)
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]
(In reply to Chris Lord [:cwiiis] from comment #7)
> Discussing this in bug 1227789. Assigning to me for now so we don't lose
> track of it, but I may not have time to deal with this before PTO.

Feel free to assign this to me if you don't get to it before going on PTO.

Updated

3 years ago
Duplicate of this bug: 1227789
Ok, I'm not going to get the time to get to this before PTO, sorry :(
Assignee: chrislord.net → botond
I think we might have to back out bug 1222524 for now. We don't have cycles to fix this properly right now either.
Assignee: botond → bugmail.mozilla
Fixed by backout: https://hg.mozilla.org/mozilla-central/rev/f61e7d37cd1b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
This issue is verified fixed in Flame 2.6 and Aries 2.6.

Environmental Variables:
Device: Aries 2.6 [Full Flash]
BuildID: 20151203121905
OTAID: 20151203120657
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: FlameKK 2.6 [Full Flash][512mb]
BuildID: 20151203053521
Gaia: 97266c579c544f5ba57a701f39893cc86d46774a
Gecko: 85cf2e720a8405c43eabc9b34cce381b66d25ef9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
The correct apps are opening in the task manager and on the home screen when attempting to open apps.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(jmercado)
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.