If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[e10s] Full black screen on any website

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: fireattack, Unassigned, NeedInfo)

Tracking

({regression})

45 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8691660 [details]
black screen screenshot

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151123113812

Steps to reproduce:

Steps to reproduce:

1. Open Nightly on a fresh profile
2. Visit any website, (any site from new tab tiles or other sites)

Non-e10s windows work flawlessly.
If disabled hardware acceleration, it works flawlessly.
It works flawlessly on 43 beta.
All Fx's internal pages (about: pages, for example) has no problem, too.

I'm using offical Intel driver of 9.17.10.4229 (2015/5/27). My GPU are Intel HD Graphics 3000+AMD Raedeon HD 7400M (not actually used on Firefox).

Graphics
Adapter Description	Intel(R) HD Graphics 3000
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Asynchronous Pan/Zoom	wheel input enabled
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
Device ID	0x0116
Direct2D Enabled	true
DirectWrite Enabled	true (10.0.10586.0)
Driver Date	10-31-2015
Driver Version	10.17.10.4229
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	167f103c
Supports Hardware H264 Decoding	Yes
Vendor ID	0x8086
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0


Actual results:

The whole screen turns black. 


Expected results:

It shouldn't.
(Reporter)

Updated

2 years ago
Keywords: regression
See Also: → bug 1176506
Are you sure your GPU is supported on Windows 10? I cannot find a Windows 10 driver for your device:
https://downloadcenter.intel.com/product/81500/Intel-HD-Graphics-3000-for-2nd-Generation-Intel-Core-Processors

If it's not supported and disabling HWA works around this then we should probably just blacklist your hardware.
Flags: needinfo?(milan)
Whiteboard: gfx-noted
(Reporter)

Comment 2

2 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #1)
> Are you sure your GPU is supported on Windows 10? I cannot find a Windows 10
> driver for your device:
> https://downloadcenter.intel.com/product/81500/Intel-HD-Graphics-3000-for-
> 2nd-Generation-Intel-Core-Processors
> 
> If it's not supported and disabling HWA works around this then we should
> probably just blacklist your hardware.

Yes, it's not officially supported by Intel any more. So if the only thing going to happen on this problem is "just blacklist it", I will fully respect your decision. 

But if you don't mind, I sincerely want to bring some more information about a broader problem about this.

As you can see above, my GPU is HD3000 + AMD Raedeon HD 7400M, which is a very common switchable graphics setup on notebooks around 2011. Yes, the support of Intel 2 gen HD Graphics is officially stopped on Win 10, despite it works just fine in most of cases. But what is more important is, AMD Raedeon HD 7400M is still officially supported on Win 10 by AMD. However, we can't use it on Firefox, either: because in official driver manager (AMD Catalyst, which is used to assign GPUs to programs), Firefox (along with many other browsers like Chrome and IE) is locked on "power saving GPU (i.e. Intel's)". This is really in a dilemma, we have a legit GPU for win 10 but we can't use it on most used applications nowadays: browsers; while the one it forces us to use is not even officially supported by Win 10..

There is an *unofficial* solution to this, though: a famous unofficial driver, called UnifL, simply unlocks the freedom to choose GPUs on every program.

After using this 3rd party driver, we (old notebook users) can freely assign AMD GPU to Firefox, or Chrome. Please notice that even we used 3rd party driver to enable this option, AMD Raedeon HD 7400M is technically officially supported on Win 10 and should be supported by Firefox too, IMHO. But the reality is, it doesn't work. On Chrome, it works flawlessly* if you force it on AMD's GPU. On Firefox, it doesn't even recognize the discrete AMD GPU at all. On the forum of UnifL there is literally a sticked thread about Firefox: http://leshcatlabs.net/forums/viewtopic.php?f=8&t=1128

To be fair, I'd admit that at least some of our hardware is indeed outdated (2 gen Intel) and we are using a 3rd driver for AMD GPU, which is supposed to receive less support. But still, if we can take sometime to improve this a little bit, it would be very, very appreciated.

As we all know, recently websites are very resource intensive. I now have to exclusively use Chrome for videos, streams or any other complicate websites.

The most ironic thing is, even with the "sacrifice" of legacy hardware support, the performance on up-to-date hardware is still catastrophic on notebooks with switchable graphics: bug 1099354.

*you need to add a parameter "--disable-gpu-driver-bug-workarounds" to make it work.

Comment 3

2 years ago
Created attachment 8718881 [details]
No problem with Intel(R) HD Graphics 2000, Graphics info

WFM in latest Nightly versions always, with Intel(R) HD Graphics (2000), e10s on, no GPU #2, in Win8.1 & 10. I have never seen the black screen problem.
(Reporter)

Comment 4

2 years ago
(In reply to YF (Yang) from comment #3)
> Created attachment 8718881 [details]
> No problem with Intel(R) HD Graphics 2000, Graphics info
> 
> WFM in latest Nightly versions always, with Intel(R) HD Graphics (2000),
> e10s on, no GPU #2, in Win8.1 & 10. I have never seen the black screen
> problem.

It seems fixed recently. Not sure if it's because of driver update, Windows update or Nightly update. I will close this one for now. (Current Graphics info just in case)

-----
Adapter Description	Intel(R) HD Graphics 3000
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Asynchronous Pan/Zoom	wheel input enabled; touch input enabled
ClearType Parameters	D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200 ]
Device ID	0x0116
Direct2D Enabled	true
DirectWrite Enabled	true (10.0.10586.0)
Driver Date	11-3-2015
Driver Version	10.17.10.4229
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	167f103c
Supports Hardware H264 Decoding	Yes
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D11 vs_4_1 ps_4_1)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Comment 5

2 years ago
(In reply to Benjamin Peng from comment #4)
> (In reply to YF (Yang) from comment #3)
> > Created attachment 8718881 [details]
> > No problem with Intel(R) HD Graphics 2000, Graphics info
> > 
> > WFM in latest Nightly versions always, with Intel(R) HD Graphics (2000),
> > e10s on, no GPU #2, in Win8.1 & 10. I have never seen the black screen
> > problem.
> 
> It seems fixed recently. Not sure if it's because of driver update, Windows
> update or Nightly update.

A reminder, re-test the bug 1225285 & bug 1144457 may be a good idea.
You need to log in before you can comment on or make changes to this bug.