Closed Bug 1227804 Opened 4 years ago Closed 4 years ago

Marionette test to ensure all audio channels can be played in foreground and background

Categories

(Firefox OS Graveyard :: Gaia::System::Audio Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: evanxd, Assigned: evanxd)

References

Details

Attachments

(1 file)

Marionette test to ensure normal audio channel cannot be played in background.
Assignee: nobody → evan
Debugging the failure[1]
```
TEST-UNEXPECTED-FAIL | apps/system/test/marionette/audio_channel_played_in_background_test.js | Audio channel played in background Normal audio channel Normal audio channel cannot be played in background
AssertionError: false == true
```

[1]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=6852206a94064a04bfe1baad26659e65aaf304c0&selectedJob=3220312
Duplicate of this bug: 1227805
Summary: Marionette test to ensure normal audio channel cannot be played in background. → Marionette test to ensure normal audio channel cannot be played in background but other audio channels can be.
Updated patch[1]: reuse AudioChannelHelper in `apps/system/test/marionette/audio_channel_competing_test.js` test.

[1]: https://github.com/evanxd/gaia/commit/bb200ac6cc573ec920f8d696c6f15c282276e661
Summary: Marionette test to ensure normal audio channel cannot be played in background but other audio channels can be. → Marionette test to ensure all channel can be played in foreground and background
Because of Bug 1190434, the normal audio channel also can be played in background.
Summary: Marionette test to ensure all channel can be played in foreground and background → Marionette test to ensure all audio channels can be played in foreground and background
Comment on attachment 8701368 [details] [review]
[gaia] evanxd:bug-1227804 > mozilla-b2g:master

Hi Alastor,

Could you review the patch?

Thanks.
Attachment #8701368 - Flags: review?(alwu)
Comment on attachment 8701368 [details] [review]
[gaia] evanxd:bug-1227804 > mozilla-b2g:master

LGTM, thanks!
Attachment #8701368 - Flags: review?(alwu) → review+
Alastor, thanks for the review.
master: https://github.com/mozilla-b2g/gaia/commit/d3ecbbedaca1eaec4ec00a2a5db687baa1fc1923
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.