Closed Bug 1227808 Opened 4 years ago Closed 4 years ago

[TV 2.5] Change the settings of Authorized Devices in Remote Control feature to a simple object instead of a serialized string

Categories

(Firefox OS Graveyard :: Gaia::TV, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: lchang, Assigned: lchang)

References

Details

(Whiteboard: [partner-cherry-pick])

Attachments

(1 file)

In bug 1197749 comment 22, the reviewer reminded us that it's unnecessary to serialize an object in settings. Let's fix it in Gaia as well.
Comment on attachment 8692401 [details] [review]
[gaia] luke-chang:1227808_tv_remote_control_settings_object > mozilla-b2g:master

Hi Rex,

Please help on this trivial patch. Thanks.
Attachment #8692401 - Flags: review?(rexboy)
[Blocking Requested - why for this release]:

This patch is required according to Gecko's implementation in bug 1197749.
Assignee: nobody → lchang
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.5?
Whiteboard: [partner-cherry-pick]
Attachment #8692401 - Flags: review?(rexboy) → review+
Comment on attachment 8692401 [details] [review]
[gaia] luke-chang:1227808_tv_remote_control_settings_object > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): TV Remote Control feature.
[User impact] if declined: the feature should be broken.
[Testing completed]: yes.
[Risk to taking this patch] (and alternatives if risky): low. It affects the remote control app only.
[String changes made]: N/A
Attachment #8692401 - Flags: approval-gaia-v2.5?
Comment on attachment 8692401 [details] [review]
[gaia] luke-chang:1227808_tv_remote_control_settings_object > mozilla-b2g:master

Approve fro TV 2.5 Remote Control
Attachment #8692401 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
blocking-b2g: 2.5? → 2.5+
You need to log in before you can comment on or make changes to this bug.