bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[TV] FTE layout of option menu is incorrect

VERIFIED FIXED

Status

Firefox OS
Gaia::TV
P2
normal
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Alison Shiue, Assigned: rexboy)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8691713 [details]
IMG_4372.JPG

STR:
1. Go to TV or Apps
2. First time open option menu

Expected result:
1. The layout should follow visual spec, please refer: https://goo.gl/AQZBFo, FTE_v0.5.pdf page 6.

Actual result:
1. Inconsistent with visual design, please refer the attached image


Build info:
Build ID               20151121125805
Gaia Revision          e63c07af8cc636b9ffac2c20f9b8ad7e7fe2b977
Gaia Date              2015-11-24 03:47:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/abbd213422a560f1180c4ec6e3bf4792c2ea81ba
Gecko Version          45.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.worker.20151121.121712
Firmware Date          Sat Nov 21 12:17:28 UTC 2015
Bootloader             HHZ12f
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=TV FTU]
Flags: needinfo?(rexboy)

Updated

3 years ago
Assignee: nobody → rexboy
Priority: -- → P1

Updated

3 years ago
blocking-b2g: --- → 2.5+
Whiteboard: [ft:conndevices][partner-cherry-pick]
If the 'incorrect' means the screen should be pixel-perfect with the screenshot on visual spec, there are issues to the visual spec.

1.top margin of the pin button is inconsistent between screenshot and the marked value.
2.width of prompt text area is not given.
Flags: needinfo?(rexboy)
Anyway this needs to confirm with visual. I'll update the status after discussing.

Comment 3

3 years ago
Josh, I don't think visual polish is a P1 issue. What do you think?
Flags: needinfo?(jocheng)
Created attachment 8692412 [details] [review]
[gaia] rexboy7:1227811-FTE-pintohome-layout > mozilla-b2g:master
Comment on attachment 8692412 [details] [review]
[gaia] rexboy7:1227811-FTE-pintohome-layout > mozilla-b2g:master

the patch is relatively simple, but we can still discuss the priority anyway.
Attachment #8692412 - Flags: review?(lchang)

Updated

3 years ago
Flags: needinfo?(jocheng)
Priority: P1 → P2
Summary: [TV] FET layout of option menu is incorrect → [TV] FTE layout of option menu is incorrect
Comment on attachment 8692412 [details] [review]
[gaia] rexboy7:1227811-FTE-pintohome-layout > mozilla-b2g:master

R+ since it's a UI polishing patch.
Attachment #8692412 - Flags: review?(lchang) → review+
master
https://github.com/mozilla-b2g/gaia/commit/ee6d8625c9d76de2f6614c87bb82b301bc37c7a9
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Comment on attachment 8692412 [details] [review]
[gaia] rexboy7:1227811-FTE-pintohome-layout > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): feature polish
[User impact] if declined: small
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): small, just css change
[String changes made]:no
Attachment #8692412 - Flags: approval-gaia-v2.5?

Updated

3 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → fixed

Comment 9

3 years ago
Comment on attachment 8692412 [details] [review]
[gaia] rexboy7:1227811-FTE-pintohome-layout > mozilla-b2g:master

Approve for TV FTE
Attachment #8692412 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+

Comment 11

2 years ago
Verify this issue on the latest build.
FTE layout of option menu matches the document "FTE_v0.6.pdf".
[Build Info]
Environment: 2.6 Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/d9faad5c0f14fcd42f920c9104f0638f46a48b2a
gecko:
https://hg.mozilla.org/mozilla-central/rev/789a12291942763bc1e3a89f97e0b82dc1c9d00b
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.