[TV][browser] compress pocket menu icon

RESOLVED FIXED

Status

Firefox OS
Gaia::TV::Browser
P3
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: danhuang, Assigned: danhuang)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [partner-cherry-pick][ft:conndevices][partner-blocker])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
The icon image in pocket menu item didn't compressed. We need to commit the compressed icon image.
(Assignee)

Updated

2 years ago
Assignee: nobody → dhuang
Blocks: 893583, 1194109
Status: NEW → ASSIGNED
Priority: -- → P3
Whiteboard: [partner-cherry-pick][ft:conndevices][partner-blocker]
(Assignee)

Updated

2 years ago
Depends on: 1220380
(Assignee)

Updated

2 years ago
Status: ASSIGNED → NEW
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED

Comment 1

2 years ago
Created attachment 8692859 [details] [review]
[gaia] danhuang1202:1227836_compress_pocket_menu_block_icon > mozilla-b2g:master
(Assignee)

Comment 2

2 years ago
Comment on attachment 8692859 [details] [review]
[gaia] danhuang1202:1227836_compress_pocket_menu_block_icon > mozilla-b2g:master

Hi Yi-fan, please help review. This patch compress pocket menu block's icon. The compress result is bellow:

$ ./tools/png_recompress.sh -v tv_apps/browser/style/images/pocket_icon.png

tv_apps/browser/style/images/pocket_icon.png 293608 489 0.001
Number of files processed: 1
Total size of the files prior to recompression: 293608
Total size of the files after recompression: 489
Compression ratio: 0.001
Attachment #8692859 - Flags: review?(yliao)
Comment on attachment 8692859 [details] [review]
[gaia] danhuang1202:1227836_compress_pocket_menu_block_icon > mozilla-b2g:master

Thanks!
Attachment #8692859 - Flags: review?(yliao) → review+
(Assignee)

Comment 4

2 years ago
Thanks for the review!
Merge in master: https://github.com/mozilla-b2g/gaia/commit/25635a698329ea46c69d382393929dea368a61a9
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

2 years ago
Comment on attachment 8692859 [details] [review]
[gaia] danhuang1202:1227836_compress_pocket_menu_block_icon > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1194109
[User impact] if declined: Image size would be too bigger in gaia app
[Testing completed]:https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=812ec28a8c9b542dfa4bdc77d4abf62795684657
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8692859 - Flags: approval-gaia-v2.5?

Updated

2 years ago
blocking-b2g: --- → 2.5+
status-b2g-v2.5: --- → affected
status-b2g-master: --- → fixed

Comment 6

2 years ago
Comment on attachment 8692859 [details] [review]
[gaia] danhuang1202:1227836_compress_pocket_menu_block_icon > mozilla-b2g:master

Approve for TV 2.5
Attachment #8692859 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
for 2.5 https://github.com/mozilla-b2g/gaia/commit/935a535bf98aafcc01dac30a6e611f4c3b8f1c34
status-b2g-v2.5: affected → fixed
You need to log in before you can comment on or make changes to this bug.