VIMP Continuous App Restart On Allwinner A10 and Test on TV SMART BOX based on ROCKCHIP RK29XX

RESOLVED WONTFIX

Status

B2GDroid Graveyard
General
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Sagar Sawant, Unassigned, Mentored)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Installed b2gdroid app on my 5 year old AllwinnerA10 based WiFi tablet. 512MB ram and 4GB ROM with Android 4.0.3

What happened? (actual results)

On setting it as the default homescreen and launcher, the app starts loading with the white FirefoxOs screen then it shows FoxFood Community Edition Blue screen and then it shows the normal homescreen with the app icons. 

but it keeps on restarting itself endlessly. The restart stops if I manage to click on the icons and launch an android app. but if I keep the show cup usage overlay on the screen, the I see that after the android app launches the process org.mozilla.b2gdroid terminates and after the app is exited the process again starts.

So two problems 

1. The b2gdroid app always restarts itself if no action is taken.
2. If an android app is launched then the process b2gdroid is terminated and it relaunches after the app closes.


What should have happened? (expected results)

Well, simple.

FirefoxOS should have been loaded stable.
(Reporter)

Updated

3 years ago
Keywords: topcrash-android-armv7
Keywords: topcrash-android-armv7
It's very likely an OOM issue, which is not surprising on a device with 512MB of RAM.
(Reporter)

Comment 2

3 years ago
(In reply to [:fabrice] Fabrice Desré from comment #1)
> It's very likely an OOM issue, which is not surprising on a device with
> 512MB of RAM.

Well in India FirefoxOS runs on 128MB ram and 256MB ram phones.

So 512MB is huge considering this.

Is it that FFOS app requires lot of RAM?

Secondly, why is it that once an android app launches the org.mozilla.b2gdroid process is terminated?

Thirdly, respecting your OOM diagnosis, I am thinking of adding a 1GB swap on a microSD and again trying to load.

Will post the results.
(Reporter)

Comment 3

3 years ago
I have also loaded it on a ROCKCHIP RK29XX chip based TV SMART BOX and
Summary: VIMP Continuous App Restart On Allwinner A10 → VIMP Continuous App Restart On Allwinner A10 and Test on TV SMART BOX based on ROCKCHIP RK29XX
(Reporter)

Comment 4

3 years ago
Its loads homescreen and am able to access the FFOS settings app and load ffos preloaded apps like contacts.

But there is no way to go to homescreen as I am using a mouse since its a TV.

The smart box i have has HDMI and Composite AV and tested using both and its fine.

But need to know how to go to home screen from an app as there is no button.

Also, can there be a shutdown option in software just like a PC? Especially useful on a TV interface but also useful to clean shutdown in case the hardware button is not working properly.

Again will try to post screen shots and video if possible.
(Reporter)

Comment 5

3 years ago
Created attachment 8692784 [details]
Screen shot of top output when the FFOS APP is loading on tablet Allwinner A10

This is screen shot of top command when the FFOS APP is loading on the tablet Allwinner A10 processor and 512 MB ram only wifi. Android 4.0.3

After Fabrice Suggestion of OOM ... I added a 2GB swap via a SD card ... and yipie ... the FIREFOX OS APP load on this tablet ...
 
But if the tablet locks then again it restarts itself. which means I have to disable autolock of android.

All in all if android apps run then FirefoxOSAPP restarts itself. rather tahn showing the FFOS home screen once the app is backgrounded or discarded or exited.
(Reporter)

Comment 6

3 years ago
FABRICE you were right its an OOM issue ... at least for now.

With the swap partition in place the FFOS app has also become fast.

NOW We need to solve the FFOS APP restart issue if the screen is locked or android app is started and exited.
(Reporter)

Comment 7

3 years ago
Also observed this process

/data/data/org.mozilla.bg2droid/lib/li 

consumes a lot of CPU ... at least 15% and there are 2 such processes ...

So it consumes at least 30% of CPU

org.mozilla.bg2droid process on an average consumes 20% of CPU

So about 50% of CPU usage.
(Reporter)

Comment 8

3 years ago
And for the swap to work well, I have also added vm.swappiness=0 in the /etc/sysctl.conf file to hint to the kernel to prefer swapping more.

Wifi does not work via FFOS settings ... it just keeps on searching for wifi access points/networks

But if I switch on wifi and connect it from android setting and then browse using the FFOS APP browser ... I get the connectivity. I can browse.
(Reporter)

Comment 9

3 years ago
youtube videos play well cpu usage

org.mozilla.bg2droid 20%
/data/data/org.mozilla.bg2droid/lib/li 25%
(Reporter)

Comment 10

3 years ago
Videos and Photos presend on the internal memory of Tablet are not detected by FFOS APP Gallery and VIDEO apps
(Reporter)

Comment 11

3 years ago
Another new observation is that if I leave the homescreen idle and do not oprate the tablet, again the b2gdroid app restarts.

Probably the time taken to load from the slow swap on the sd card is the reason.

But for sure the b2gdroid app loads well on low ram devices if swap is enabled and mounted via root.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.