Closed Bug 1228004 Opened 4 years ago Closed 3 years ago

Firefox 42 removes keywords from bookmarks with %s and pseudo protocols (like private:)

Categories

(Toolkit :: Places, defect)

42 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1285142

People

(Reporter: emailmeat, Unassigned)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

I've been using bookmarks with keywords (%s parameters) and the private: pseudo-protocol handler from the Private Tab extension for years. For example:

URL: private:http://wordreference.com/enru/%s
keyword: enru

See the screenshot for reference.




Actual results:

This always worked as expected, but starting from Firefox 42, I can't add keywords to bookmarks that have private: and %s in their URL fields. Firefox automatically remove the keyword as soon as I click on another keyboard. I've tested other pseudo protocols like testtest: , and the same happens. A test on a Windows XP virtual machine has confirmed that this isn't related to my specific profile or other extensions.


Expected results:

The keyword should be saved normally, as it has always been for years.
Component: Untriaged → Places
Product: Firefox → Toolkit
it seems to be working for me, I created a new bookmark, set the url to "private:http://wordreference.com/enru/%s" and set keyword to "test"

Now this exposes a bug in the Location Bar where typing the keyword wrongly shows the moz-action: url.
And it's likely subject to bug 1150678.

Can you better specify where do you see Firefox is removing the keyword?
Marco, did you create more than one bookmark? Do it in the Library, then select the first one and then the second  one again.
More than one bookmark for the same keyword?
That's no more supported
Marco, I know that. I said I've been using this feature for years. I meant that the keyword disappears when I click on other bookmarks - any boookmark -, so just creating a single bookmark may not be enough to reproduce it. 

I've made screencasts on my main Windows 10 installation and my Windows XP virtual machine (with a completely clean profile). See the new attached files.

It turns out it happens even without the %s parameter. "private:" is enough to trigger the bug.
that is bug 1150678 the UI is completely broken at the moment when changing either the keyword or the url.
I've never had the problem described in that bug. I'm able to edit and use keywords normally right now. The problem only happens when I enter private: (or any other "pseudo-protocol").
that doesn't matter, what you are doing is changing the url, and that's currently broken...
Depends on: 1150678
I'm able to edit both keywords and URLs. I just changed it to http://www.wordreference.com/enrreauraeu/%s and the keyword to "reaura" and it worked.
it "works" but it mistakenly associates keywords to urls and also creates orphan keywords. That's why the keyword disappear.
These problems may be related, but I'm concerned about your closing this bug because it happens even if I create new bookmarks with private: and a keyword. It happens even if I don't edit any fields.
I did not close it, so we can check after bug 1150678 is fixed.
What you are doing when entering a new bookmark is an url change, due to how the panel works internally.
Following on https://bugzilla.mozilla.org/show_bug.cgi?id=1285142 .

My report is older but got less attention for being more specific.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1285142
You need to log in before you can comment on or make changes to this bug.