Crash occurs when attempting to access iTool sign up page

VERIFIED DUPLICATE of bug 122792

Status

()

Core
Plug-ins
--
critical
VERIFIED DUPLICATE of bug 122792
16 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: av (gone))

Tracking

({crash, regression})

Trunk
PowerPC
Mac OS X
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build: 2002-01-31-08
Platform: OS X
Expected Results: After clicking link, Page should load in browser
What I got: Crash occurs.

Steps to reproduce:
1) Go to http://itools.mac.com/WebObjects/iTools.woa?aff=consumer&cty=US&lang=en
2) Click on Sign Up image
3) Message appears "You have requested a encrypted page" Click OK.
4) URL chages to
https://itools.mac.com/WebObjects/Signup.woa/1/wa/parsePlugInISWO1001001SOSriIZrobwQkoBVmDB.5
(Reporter)

Comment 1

16 years ago
After step 5, the application crashes:


**********

Date/Time:  2002-01-31 10:12:34 -0800
OS Version: 10.1.2 (Build 5P48)

Command:    Netscape 6
PID:        285

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x6b259698

Thread 0:
 #0   0x0053ea64 in SubBlock_construct
 #1   0x00000000 in 0x0
 #2   0x0053e834 in Block_subBlock
 #3   0x0053ef10 in allocate_from_var_pools
 #4   0x0053f674 in _pool_alloc
 #5   0x0053f990 in malloc
 #6   0x004f02b0 in PR_Malloc
 #7   0x005fc9b0 in Alloc__12nsMemoryImplFUl
 #8   0x0061a910 in Alloc__8nsMemoryFUl
 #9   0x00620d48 in Alloc__5nsStrFR5nsStrUi
 #10  0x00620e88 in Realloc__5nsStrFR5nsStrUi
 #11  0x0061dfec in EnsureCapacity__5nsStrFR5nsStrUi
 #12  0x0061e0e4 in GrowCapacity__5nsStrFR5nsStrUi
 #13  0x0061e338 in StrAppend__5nsStrFR5nsStrRC5nsStrUii
 #14  0x006265dc in AppendWithConversion__8nsStringFPCci
 #15  0x00626490 in AssignWithConversion__8nsStringFPCc
 #16  0x02600614 in 0x2600614
 #17  0x0318758c in PostURL__16nsPluginHostImplFP11nsISupportsPCcUiPCciPCcP23nsIPl
 #18  0x0317bfd8 in posturlnotify
 #19  0x04b48508 in 0x4b48508
 #20  0x04b475e8 in 0x4b475e8
 #21  0x04b460b8 in 0x4b460b8
 #22  0x04b45ae8 in 0x4b45ae8
 #23  0x04b44de0 in 0x4b44de0
 #24  0x04b479d0 in 0x4b479d0
 #25  0x04b487b0 in 0x4b487b0
 #26  0x03178f2c in CleanUpStream__24ns4xPluginStreamListenerFs
 #27  0x03179a74 in OnStopBinding__24ns4xPluginStreamListenerFP19nsIPluginStreamIn
 #28  0x03184f9c in OnStopRequest__26nsPluginStreamListenerPeerFP10nsIRequestP11ns
 #29  0x02ec6164 in OnStopRequest__19nsStreamListenerTeeFP10nsIRequestP11nsISuppor
 #30  0x02ed9cc4 in OnStopRequest__13nsHttpChannelFP10nsIRequestP11nsISupportsUi
 #31  0x02ecc1f0 in HandleEvent__20nsOnStopRequestEventFv
 #32  0x02ecb600 in HandlePLEvent__23nsARequestObserverEventFP7PLEvent
 #33  0x005e82c0 in PL_HandleEvent
 #34  0x005e812c in PL_ProcessPendingEvents
 #35  0x0058e5cc in ProcessPendingEvents__16nsEventQueueImplFv
 #36  0x0362ba3c in ProcessPLEventQueue__26nsMacNSPREventQueueHandlerFv
 #37  0x0362b800 in RepeatAction__26nsMacNSPREventQueueHandlerFRC11EventRecord
 #38  0x01846b14 in DoRepeaters__8RepeaterFRC11EventRecord
 #39  0x0363f718 in DispatchEvent__16nsMacMessagePumpFiP11EventRecord
 #40  0x0363f2f0 in DoMessagePump__16nsMacMessagePumpFv
 #41  0x0363ec2c in Run__10nsAppShellFv
 #42  0x01bb9e3c in Run__17nsAppShellServiceFv
 #43  0x004baba4 in main1__FiPPcP11nsISupports
 #44  0x004bb67c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x7003f2b8 in _pthread_cond_wait
 #3   0x70283ea4 in TSWaitOnConditionTimedRelative
 #4   0x7027d748 in TSWaitOnSemaphoreCommon
 #5   0x702c2078 in TimerThread
 #6   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body


PPC Thread State:
  srr0: 0x0053ea64 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x00000020   lr: 0x0053eb18  ctr: 0x0053f970   mq: 0x00000000
    r0: 0x666f6df6   r1: 0xbfffe150   r2: 0x000db000   r3: 0x04b628a8
    r4: 0x666f6df0   r5: 0x093c2f52   r6: 0x00000001   r7: 0x00000001
    r8: 0x00000000   r9: 0x00000000  r10: 0x00000000  r11: 0x80003710
   r12: 0x000dc9a0  r13: 0x00000000  r14: 0x00000033  r15: 0x0005e660
   r16: 0x00000001  r17: 0x80160fa8  r18: 0x00058528  r19: 0x00001707
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004234  r23: 0x700042c8
   r24: 0x7016b0dc  r25: 0x006bac3c  r26: 0x8081ab5c  r27: 0xc0dc2000
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x00000000  r31: 0x00000001

**********



(Reporter)

Comment 2

16 years ago
Sorry, there should only be four steps to reproduce this problem.
(Reporter)

Updated

16 years ago
Severity: normal → critical
Keywords: crash, regression

Comment 3

16 years ago
also reported in bug 122792

Comment 4

16 years ago
RkAa, u are so modest! :)  Marking dup !

*** This bug has been marked as a duplicate of 122792 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.