Closed Bug 1228056 Opened 6 years ago Closed 6 years ago

Anniversary/birthday date is the day before selected in contacts

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master affected)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-v2.5 --- affected
b2g-master --- affected

People

(Reporter: AdamA, Assigned: zbraniecki)

References

()

Details

(Keywords: regression, Whiteboard: [2.6-Daily-Testing][Spark])

Attachments

(2 files)

Attached file logcat
Description:
if the user is making or editing a contact and sets the anniversary or birthday date it will display as the day before the user selected after exiting the picker wheel.

Repro Steps:
1) Update a Aries to 20151125130040
2) Open contacts
3) Make a new contact
4) Set the birthday or anniversary date
5) Observe date after exiting selection

Actual:
the date is set for the day before the user selected

Expected:
It is expected that the date selected is the displayed date in the contact

Environmental Variables:
Device: Aries 2.6 [Full flash]
Build ID: 20151125130040
Gaia: 9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gecko: 1835baed2a38429a3cc301d21778a113d3a9e7d8
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: video clip, logcat
This issue DOES occur on Flame 2.6 and Flame 2.5.

Environmental Variables:
Device: Flame 2.6 [Full Flash][512mb]
BuildID: 20151125030226
Gaia: 37250b125e0db6966875d3b37b117f6d9b76cbc0
Gecko: 099f695d31326c39595264c34988a0f4b7cbc698
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.5 [Full Flash][512mb]
BuildID: 20151125122518
Gaia: 93b8bf2de3258c25199d97036c50a87667059148
Gecko: 913818c231658f959ce779ce2763ddb864024057
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
the date is set for the day before the user selected
-------------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash][512mb]
BuildID: 20151125032502
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 462d8e9208ea
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
the date is set for the correct date
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
[Blocking Requested - why for this release]:

Regression and not a good end user experience.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: sleedavid
blocking-b2g: 2.5? → 2.5+
Regression Window: B2G Inbound

Last working
Device: Flame 2.5
BuildID: 20150929161608
Gaia: dc08670f216fc9bc13568f74db8550035c055f14
Gecko: 87093409f76314f8c089e829745c6a2c0e4543db
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken 
Device: Flame 2.5
BuildID: 20150929171515
Gaia: 342f5b3f7865e68b1885258c53c23204f6da1b97
Gecko: f94013a1052827c97df94fba98afd2f1bcc886e9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0


Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Device: Flame 2.5
BuildID: 20150929171515
Gaia: dc08670f216fc9bc13568f74db8550035c055f14
Gecko: f94013a1052827c97df94fba98afd2f1bcc886e9

First Broken Gaia Last Working Gecko: Issue DOES reproduce 
Device: Flame 2.5
BuildID: 20150929161608
Gaia: 342f5b3f7865e68b1885258c53c23204f6da1b97
Gecko: 87093409f76314f8c089e829745c6a2c0e4543db

Pushlog
https://github.com/mozilla-b2g/gaia/compare/dc08670f216fc9bc13568f74db8550035c055f14...342f5b3f7865e68b1885258c53c23204f6da1b97

May have been caused due to changes made by Bug 1206306.
Blocks: 1206306
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Contact: sleedavid
Great catch! I found the cause.
Assignee: nobody → gandalf
Comment on attachment 8693860 [details] [review]
[gaia] zbraniecki:1228056-use-normalizedDate-for-dateFormatting > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1206306
[User impact] if declined: The birthday/anniversary date will be displayed as one-day-off
[Testing completed]: on device
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8693860 - Flags: review?(francisco)
Attachment #8693860 - Flags: approval-gaia-v2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Attachment #8693860 - Flags: review?(francisco) → review+
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/f559d2457bbb1720582a7e4d4a6f277a4b18fffb
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Uplifted to nga branch:

45e8d43
The birthday and anniversary dates are now correct when making a contact on Flame 2.6 and Aries 2.6.

Environmental Variables:
Device: Aries 2.6 [Full Flash]
BuildID: 20151202153750
OTAID: 20151202152521
Gaia: 719d89803fd1809bb1132e564a6d0c255963d4b7
Gecko: a0897ec629f90951e685f42eefecea8437481ecb
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: FlameKK 2.6 [Full Flash][512mb]
BuildID: 20151202030236
Gaia: 7847a3c1b28e039631509978518b36fd3c5f9585
Gecko: 470f4f8c2b2d6f82e56e161a4b05262c85f55b59
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
The date is the same as the set one.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Comment on attachment 8693860 [details] [review]
[gaia] zbraniecki:1228056-use-normalizedDate-for-dateFormatting > mozilla-b2g:master

Limiting 2.5 only to TV patches. Foxfooders are getting updates from master/b2g-ota branch. Removing the uplift nomination.

Thank you
Attachment #8693860 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5-
You need to log in before you can comment on or make changes to this bug.