Closed Bug 1228066 Opened 4 years ago Closed 4 years ago

Dark dev theme location bar text rendered as black on black

Categories

(Firefox :: Theme, defect)

x86_64
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 45
Tracking Status
firefox45 --- verified

People

(Reporter: mhowell, Assigned: Gijs)

References

Details

Attachments

(3 files)

STR:
1) Open a tab.
2) Either browse to a URL or type something (search terms, URL, etc.) into the URL bar.

Expected result:
The URL or the entered text is visible in the bar.

Actual result:
The URL or the entered text cannot be seen unless you select it. Looking very closely at where the text should be reveals that it is actually there, just rendered in black.

The placeholder text (the "Search or enter address" message on a new tab) is visible as normal.

I've attached a screenshot so you can see what the problem looks like vs. the working light theme.
Attached file about:support info
The same problem also appears in safe mode.
I probably broke this in bug 1226110.
Blocks: 1226110
Ugh, sorry. Either this or adding :-moz-lwtheme to the selector should work, I think (we are currently failing to do the right thing because of https://dxr.mozilla.org/mozilla-central/rev/099f695d31326c39595264c34988a0f4b7cbc698/browser/themes/windows/browser.css#1239 ).
Attachment #8692101 - Flags: review?(dao)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
(In reply to :Gijs Kruitbosch from comment #4)
> Created attachment 8692101 [details] [diff] [review]
> fix urlbar inherit to apply on windows,
> 
> Ugh, sorry. Either this or adding :-moz-lwtheme to the selector should work,
> I think (we are currently failing to do the right thing because of
> https://dxr.mozilla.org/mozilla-central/rev/
> 099f695d31326c39595264c34988a0f4b7cbc698/browser/themes/windows/browser.
> css#1239 ).

Yep, I applied this change manually in the browser toolbox, and the problem is gone. Thanks for getting to that so quickly.
Attachment #8692101 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/84a9d32d515f
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
QA Whiteboard: [good first verify]
status-firefox45.0a2: verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.