Cannot build fx-team on windows "WindowsError: [Error 2] The system cannot find the file specified: u'_tests\\testing\\mochitest\\browser\\devtools\\client\\aboutdebugging\\test\\addons'"

RESOLVED DUPLICATE of bug 1221141

Status

()

Firefox
Developer Tools: about:debugging
RESOLVED DUPLICATE of bug 1221141
2 years ago
2 years ago

People

(Reporter: pbro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
STR:
- I updated fx-team today, here's the revision:
changeset:   274158:8124c9b5e804
tag:         fx-team
user:        Nick Alexander <nalexander@mozilla.com>
date:        Wed Nov 25 11:11:39 2015 -0800
summary:     Bug 1227600 - Fix |mach bootstrap| bustage on Mac OS X. r=me,gps
- then ran ./mach build

And the build failed after only a minute or 2 with:
WindowsError: [Error 2] The system cannot find the file specified: u'_tests\\testing\\mochitest\\browser\\devtools\\client\\aboutdebugging\\test\\addons'

The only way I could make it work was removing this part:
BROWSER_CHROME_MANIFESTS += [
    'test/browser.ini'
]

in \devtools\client\aboutdebugging\moz.build
Should be fixed by:
  https://hg.mozilla.org/integration/fx-team/rev/b8775010b736
being an hotfix for bug 1221141.
(Reporter)

Comment 2

2 years ago
Thanks, it does work now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1221141
You need to log in before you can comment on or make changes to this bug.