using back button on isindex (serverside) search crashes mozilla

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Lars Hugentobler, Assigned: Marc Attinasi)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
how to reproduce:
-go to http://antwrp.gsfc.nasa.gov/cgi-bin/apod/apod_search
-enter search term, for example "earthlights"
-use back button

this bug appeared after 0.9.7, under i which i could not reproduce it. i have
tried several of the -0.9.8 candidates, all of which exhibited this behaviour.

Comment 1

16 years ago
WFM on build 2001122908 under Windows ME.

Comment 2

16 years ago
Another URL that's exhibiting this behavior is:

http://www2.andrews.edu/~aldy/ogre.cgi

Go to the URL; enter a chord in the text field (G will do nicely); and then,
when the new page has loaded, hit back. Or type Cmd-left. Instant crash.

Like the reporter said, this is new behavior in 0.9.8 (or perhaps late 0.9.7+
builds). And it's really annoying, too, because I use that site all the time. :-)

Using build 020411 on OS X 10.1.2. This bug should be marked all/all.

Comment 3

16 years ago
Yep, seeing this on 2002021206/linux.

Talkback TB2920374H

Comment 4

16 years ago
0x00000010
nsIsIndexFrame::SetInputValue()
nsIsIndexFrame::RestoreState()
FrameManager::RestoreFrameStateFor()
nsCSSFrameConstructor::InitAndRestoreFrame()
nsCSSFrameConstructor::ConstructHTMLFrame()
nsCSSFrameConstructor::ConstructFrameInternal()
nsCSSFrameConstructor::ConstructFrame()
nsCSSFrameConstructor::ContentAppended()
StyleSetImpl::ContentAppended()
PresShell::ContentAppended()
nsDocument::ContentAppended()
nsHTMLDocument::ContentAppended()
HTMLContentSink::NotifyAppend()
SinkContext::FlushTags()
HTMLContentSink::CloseBody()
CNavDTD::CloseBody()
CNavDTD::CloseContainer()
CNavDTD::CloseContainersTo()
CNavDTD::CloseContainersTo()
CNavDTD::DidBuildModel()
nsParser::DidBuildModel()
nsParser::ResumeParse()
nsParser::OnStopRequest()
nsDocumentOpenInfo::OnStopRequest()
nsHttpChannel::OnStopRequest()
nsOnStopRequestEvent::HandleEvent()
nsARequestObserverEvent::HandlePLEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0x11276 (0x403bd276)
libglib-1.2.so.0 + 0x12b90 (0x403beb90)
libglib-1.2.so.0 + 0x130f2 (0x403bf0f2)
libglib-1.2.so.0 + 0x13304 (0x403bf304)
libgtk-1.2.so.0 + 0xa8ede (0x402bdede)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x18108 (0x40502108) 

Comment 5

16 years ago
works4me 20020302 win2k
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
well, i'm glad that it works for you, i couldn't reproduce it on a win98 machine
either. 
nevertheless, i'm still seeing this with linux:2002030116 (0.9.9 candidate), and
since it really is marked as a os:linux bug, "worksforme" doesnt apply imho.
i admit that i'm fairly new to this, so if my attempting to reopen this bug is
wrong, please do comment why (or kindly point me to a faq i should have read
more thoroughly).
Severity: major → minor
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
-> Layout
Assignee: asa → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 8

16 years ago
Lars Hugentobler: Could you still reproduce it with recent nightbuilds?
Severity: minor → critical
Keywords: crash
(Reporter)

Comment 9

16 years ago
i'm now using 2002040808/linux, and i cannot reproduce the crash anymore.
OGRE (url mentioned by Nick Kocharhook) works as well.
thanks a lot, changing resolution to fixed.
(please comment if doing so was wrong)
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 10

16 years ago
Correct resolution is WORKSFORME (because this bug was not fixed, but problem
was fixed with another bug). (fixed -> reopen -> WFM)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

16 years ago
Marking WFM regarding reporter's comment.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.