Tracking Protection FTU Pop-Up will display improperly if viewed in landscape orientation, navigating Home, then returning in Portrait

RESOLVED DUPLICATE of bug 1223703

Status

RESOLVED DUPLICATE of bug 1223703
3 years ago
3 years ago

People

(Reporter: Marty, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8692205 [details]
logcat_Browser-Landscape.txt

Description:
Viewing the Tracking Protection FTU in Landscape, navigating to Home Screen, then returning to the Browser in Portrait will cause the Tracking Protection pop-up to be formatted improperly and cut off on the right side of the screen.

Repro Steps:
1) Update a Aries to 20151125131311
2) Launch the Browser app
3) Rotate the device to Landscape orientation.
4) Press the Home Button to go to the Home Screen
5) Rotate the device back to Portrait orientation.
6) Return to the Browser app.

Actual:
The Tracking Protection FTU will display too wide, and cur off the right side of the screen.

Expected:
The Tracking Protection FTU will display properly for portrait orientation.

Environmental Variables:
Device: Aries 2.6
Build ID: 20151125131311
Gaia: 9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gecko: 1835baed2a38429a3cc301d21778a113d3a9e7d8
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 5/5
See attached: Video (URL), Logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the latest Flame 2.6 and 2.5 builds.
The Tracking Protection FTU will display too wide, and cur off the right side of the screen.

Environmental Variables:
Device: FlameKK 2.6
BuildID: 20151125030226
Gaia: 37250b125e0db6966875d3b37b117f6d9b76cbc0
Gecko: 099f695d31326c39595264c34988a0f4b7cbc698
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: FlameKK 2.5
BuildID: 20151125122518
Gaia: 93b8bf2de3258c25199d97036c50a87667059148
Gecko: 913818c231658f959ce779ce2763ddb864024057
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Rotating the device to landscape and back to portrait resolves the issue so not nominating to block on this. Alison, can you take a look at this please?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Component: Gaia::Browser → Gaia::System::Window Mgmt
Flags: needinfo?(ktucker) → needinfo?(ashiue)
From the actual result, it is similar as bug 1223703.
See Also: → bug 1223703

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ashiue)
Resolution: --- → DUPLICATE
Duplicate of bug: 1223703
You need to log in before you can comment on or make changes to this bug.