Vimeo player misplacement

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Paul Bignier, Unassigned)

Tracking

38 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8692383 [details]
Full screen, HD off, "View actual size" activated

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20151104125556

Steps to reproduce:

Played several videos on Vimeo (for instance https://vimeo.com/ondemand/smallworldmovie), on small and full screen, HD and not HD.


Actual results:

Small screen: when I press play, the video starts buffering & the cursor goes on but only a black screen is shown (see screenshot2).

Full screen: in HD, only the black screen is ever shown, but with HD off and "View actual size" activated, a portion (about half) of the video is shown at the bottom of the screen (see screenshot).

The sound is always fine, whatever the configuration.


Expected results:

I guess the video is there, because it shows in one of the configurations and the sound always plays fine, but in all cases it should have played correctly.

Here's my about:support page:

Application Basics
------------------

Name: Firefox
Version: 38.4.0
Build ID: 20151104125556
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Multiprocess Windows: 0/1 (default: false)

Extensions
----------

Name: AdBlock for YouTube™
Version: 0.1.4
Enabled: true
ID: jid1-q4sG8pYhq8KGHs@jetpack

Name: Adblock Plus
Version: 2.6.12
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Auto Reload
Version: 1.20.1-signed
Enabled: true
ID: autoreload@yz.com

Name: Ecosia — The search engine that plants trees!
Version: 3.4.2
Enabled: true
ID: {d04b0b40-3dab-4f0b-97a6-04ec3eddbfb0}

Name: HighlightAll
Version: 1.8
Enabled: true
ID: {26FD1F83-A45B-4c74-AF5A-F2EE0EE4D691}

Graphics
--------

Adapter Description: NVIDIA Corporation -- GeForce 210/PCIe/SSE2
Device ID: GeForce 210/PCIe/SSE2
Driver Version: 3.3.0 NVIDIA 340.65
GPU Accelerated Windows: 0/1 Basic
Vendor ID: NVIDIA Corporation
WebGL Renderer: NVIDIA Corporation -- GeForce 210/PCIe/SSE2
windowLayerManagerRemote: false
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.download.manager.alertOnEXEOpen: true
browser.places.smartBookmarksVersion: 7
browser.search.suggest.enabled: false
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20151104125556
browser.startup.homepage: about:home
browser.startup.homepage_override.buildID: 20151104125556
browser.startup.homepage_override.mstone: 38.4.0
dom.mozApps.used: true
extensions.lastAppVersion: 38.4.0
media.gmp-gmpopenh264.lastUpdate: 1431686240
media.gmp-gmpopenh264.version: 1.4
media.gmp-manager.buildID: 20151104125556
media.gmp-manager.lastCheck: 1448523032
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1448523394
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.libtotem-cone-plugin: 1
plugin.state.libtotem-gmp-plugin: 1
plugin.state.libtotem-mully-plugin: 1
plugin.state.libtotem-narrowspace-plugin: 1
print.print_bgcolor: false
print.print_bgimages: false
print.print_colorspace: default
print.print_downloadfonts: false
print.print_duplex: 0
print.print_evenpages: true
print.print_in_color: true
print.print_margin_bottom: 0.5
print.print_margin_left: 0.5
print.print_margin_right: 0.5
print.print_margin_top: 0.5
print.print_oddpages: true
print.print_orientation: 1
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 279.40
print.print_paper_name: na_letter
print.print_paper_size_type: 1
print.print_paper_size_unit: 1
print.print_paper_width: 215.90
print.print_plex_name: default
print.print_resolution_name: default
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 56
print.print_unwriteable_margin_left: 25
print.print_unwriteable_margin_right: 25
print.print_unwriteable_margin_top: 25
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_colorspace: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_downloadfonts: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_jobtitle: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_num_copies: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_orientation: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_paper_size: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_plex: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_printincolor: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_resolution: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.can_change_spoolercommand: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.colorspace.0.name: default
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.colorspace.count: 1
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.has_special_printerfeatures: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.orientation.0.name: portrait
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.orientation.1.name: landscape
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.orientation.count: 2
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.0.height_mm: 210
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.0.is_inch: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.0.name: A5
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.0.width_mm: 148
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.1.height_mm: 297
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.1.is_inch: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.1.name: A4
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.1.width_mm: 210
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.2.height_mm: 420
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.2.is_inch: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.2.name: A3
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.2.width_mm: 297
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.3.height_mm: 279
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.3.is_inch: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.3.name: Letter
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.3.width_mm: 215
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.4.height_mm: 355
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.4.is_inch: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.4.name: Legal
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.4.width_mm: 215
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.5.height_mm: 431
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.5.is_inch: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.5.name: Tabloid
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.5.width_mm: 279
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.6.height_mm: 254
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.6.is_inch: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.6.name: Executive
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.6.width_mm: 190
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.paper.count: 7
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.plex.0.name: default
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.plex.count: 1
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.resolution.0.name: default
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.resolution.count: 1
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.supports_colorspace_change: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.supports_downloadfonts_change: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.supports_jobtitle_change: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.supports_orientation_change: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.supports_paper_size_change: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.supports_plex_change: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.supports_printincolor_change: true
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.supports_resolution_change: false
print.tmp.printerfeatures.CUPS/e-STUDIO2040C.supports_spoolercommand_change: false
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1446452120

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.8
Version in use: 4.10.8

NSS
Expected minimum version: 3.19.1 Basic ECC
Version in use: 3.19.1 Extended ECC

NSSSMIME
Expected minimum version: 3.19.1 Basic ECC
Version in use: 3.19.1 Extended ECC

NSSSSL
Expected minimum version: 3.19.1 Basic ECC
Version in use: 3.19.1 Extended ECC

NSSUTIL
Expected minimum version: 3.19.1
Version in use: 3.19.1

Experimental Features
---------------------

Sandbox
-------

Seccomp-BPF (System Call Filtering): true
Media Plugin Sandboxing: true
(Reporter)

Comment 1

3 years ago
Created attachment 8692386 [details]
Small screen, HD on or off

Comment 2

3 years ago
It seems that, you are using old Firefox. Could you please update to Latest Firefox [1] with a fresh profile[2] and try to reproduce the bug. 

[1] http://mzl.la/152VFwM 
[2] https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles#w_creating-a-profile
QA Whiteboard: [bugday-20151128]
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Hi Paul, can you update to version 42 of Firefox and see if you can still replicate this issue? Thanks.
Flags: needinfo?(paul.bignier)
(Reporter)

Comment 4

3 years ago
(In reply to Grover Wimberly IV from comment #3)
> Hi Paul, can you update to version 42 of Firefox and see if you can still
> replicate this issue? Thanks.

Hello,

I tried with Firefox 42 & nightly 45 but in both cases the video page wrote "This video can't be played with your current setup".
From a few researches on the web I could see that I was not the only one with that issue, but nothing I read worked for me.

I'm using CentOS 7 so that's why I'm only using Firefox 38.4 and Flash-plugin 11.2 (packaged versions).

Regards,
Paul
Flags: needinfo?(paul.bignier)
(Reporter)

Comment 5

3 years ago
Youtube worked though.
I can't reproduce on Fedora 23 with today's Nightly. Might have seen this once in the past.

Sounds like you're using flash for vimeo playback. Passing to add-ons.
Component: Audio/Video: Playback → Plug-ins
I can't reproduce, reopen if you still can.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.