[Topcrashers] KeyError when using several versions

RESOLVED FIXED

Status

Socorro
Webapp
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: adrian, Assigned: adrian)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Sentry error: https://sentry.prod.mozaws.net/operations/socorro-stage/group/156413/

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "newrelic/hooks/framework_django.py", line 499, in wrapper
    return wrapped(*args, **kwargs)
  File "crashstats/crashstats/decorators.py", line 66, in inner
    return view(request, *args, **kwargs)
  File "session_csrf/__init__.py", line 138, in wrapper
    response = f(request, *args, **kw)
  File "crashstats/crashstats/decorators.py", line 34, in inner
    return view(request, *args, **kwargs)
  File "crashstats/topcrashers/views.py", line 225, in topcrashers
    if context['version'] not in release_versions:
(Assignee)

Comment 1

2 years ago
Created attachment 8692492 [details] [review]
Link to Github pull-request: https://github.com/mozilla/socorro/pull/3116
Duplicate of this bug: 1229006

Comment 3

2 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/b0393dedf39d849342338dcf03ef7097a3ac5e46
Fixes bug 1228302 - Always set a version in context.

https://github.com/mozilla/socorro/commit/6d366557ba8dbf2d1defe222ecf52704a5a62a07
Merge pull request #3116 from AdrianGaudebert/1228302-keyerror-tcbs

Fixes bug 1228302 - Always set a version in context.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.