Put the "view data" button on rule's history page

RESOLVED DUPLICATE of bug 1109071

Status

Release Engineering
Applications: Balrog (frontend)
RESOLVED DUPLICATE of bug 1109071
3 years ago
3 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
At [1], you can see the links to Taskcluster tasks being displayed as comments. :nhirata put the information manually. This is very useful when you want to backtrack the build we sent in order to reproduce bugs (like bug 1217490). 

As Balrog already knows about the build ID delivered, and as finding the right namespace is not always easy with [2], :julienw and I propose to show the TC task, based on the mapping value.

Would this be feasible?

[1] https://aus4-admin.mozilla.org/rules/185
[2] https://tools.taskcluster.net/index/artifacts/
I'm not sure where you'd like to display or store the taskID. Could you clarify ? Please keep in mind that some releases contain updates from multiple tasks, eg B2G-gecko-nightly-latest.
(Reporter)

Comment 2

3 years ago
Created attachment 8692951 [details]
Link to task - proposal - picture

If that's possible, I think we can have it on each history item at the history page of a rule. Here's attached a picture of what I have in mind: 1 history item showing 1 task link. 

What do you think?
Ah, I see. So even though you have 'Task(s)' there, I don't think your proposal would handle multiple taskIDs in a release, which is normally the case. It also starts storing information about a release on a rule, or at least displayed there, when we have maintained a separation until now.

I was going to suggest storing the taskID in the release, but we already have that:
{
  "platforms": {
    "aries": {
      "locales": {
        "en-US": {
          "buildID": "20151113081940",
          "platformVersion": "45.0a1",
          "displayVersion": "45.0a1",
          "completes": [
            {
              "fileUrl": "https://queue.taskcluster.net/v1/task/F-hLXBKfRdORNTCoM_RHIw/runs/0/artifacts/public/build/b2g-aries-gecko-update.mar",
              "from": "*",
....

So, manually at first, the steps are
1, look at rule revisions page
2, filter down to the release of interest at https://aus4-admin.mozilla.org/releases
3, use View Data to retrieve the taskID and run number for the product of interest, eg F-hLXBKfRdORNTCoM_RHIw
4, append the taskID to https://tools.taskcluster.net/task-inspector/#, eg
     https://tools.taskcluster.net/task-inspector/#F-hLXBKfRdORNTCoM_RHIw/0
   if you want to see all the artifacts, or leave off the /0 if you want the task itself (for routes or whatever)

Step 2 can be improved in Balrog UI by adding a 'View Data' button next to the release name in rule pages (like on the release pages). Steps 3 and 4 could be eased by inserting hyperlinks into that view, eg 'View Task' next to a file URL. So leaves just a couple of clicks from rule history to taskcluster, and it supports multiple products and/or updates created in multiple tasks. What do you think ?
(Reporter)

Comment 4

3 years ago
Your proposal sounds great to me. Having the view data button on pages like [1] would help a bunch. ONce we're on that panel, if the hyperlink are not detected, it's just a matter of copy and paste. I'm renaming the bug accordingly. Thanks!

[1] https://aus4-admin.mozilla.org/rules/185
Summary: Show Taskcluster taskId in rule's history → Put the "view data" button on rule's history page
(In reply to Nick Thomas [:nthomas] from comment #3)
> Step 2 can be improved in Balrog UI by adding a 'View Data' button next to
> the release name in rule pages (like on the release pages).

I'm doing this part in bug 1109071.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1109071
You need to log in before you can comment on or make changes to this bug.