Edited context is saved even if the 'Cancel' button is pressed

RESOLVED WONTFIX

Status

P2
normal
Rank:
19
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: cbadau, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox44 affected, firefox45 affected)

Details

(Whiteboard: [investigation to determine severity in 43])

Reproducible on the latest Nightly 45.0a1(BuildID: 20151126030226)
Mozilla/5.0 (Machintosh; Intel Mac OS X 10.10; rv:45.0) Gecko/20100101 Firefox/45.0
Reproducible on the latest Aurora 44.0a2(BuildID: 20151125004042)
Mozilla/5.0 (Machintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0

Steps to reproduce: 
1. Start Firefox
2. Click Hello icon
4. Start a conversation
5. Click on the settings icon from conversation window and select 'Edit Context'
6. Complete the fields with some data and click 'Cancel'
7. Reopen 'Edit Context'

Expected results: The data entered on step 6 isn't saved (because the Cancel button was pressed). 

Actual results: The data entered on step 6 is saved even if the Cancel button was pressed. 

Note: 
1. The issue is reproducible also on Nightly 43.0a1 (buildID: 20150911030204). 
2. The issue is reproducible also on Windows 8.1 64bit.
status-firefox45: --- → affected
The bug is reproducible with and without e10s.

Comment 2

3 years ago
edit context still live in 43 - but going away.  does it only show up in the "edit context window" or does it go with conversation even if click cancel - will determine how high set.
Rank: 19
Priority: -- → P2
Whiteboard: [investigation to determine severity in 43]

Comment 3

3 years ago
Hi Camelia, this is going away - since it doesnt' send to other person "wont fixing it"
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(camelia.badau)
Resolution: --- → WONTFIX
(In reply to :shell escalante from comment #2)
> edit context still live in 43 - but going away.  does it only show up in the
> "edit context window" or does it go with conversation even if click cancel -
> will determine how high set.

Does it only show up in the "edit context window".
Flags: needinfo?(camelia.badau)
You need to log in before you can comment on or make changes to this bug.