MOZ_ASSERT(mIsRoot || !aState->GetScaleToResolution()); at layout/generic/nsGfxScrollFrame.cpp:5376

RESOLVED FIXED in Firefox 45

Status

()

Core
Layout
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gwagner, Assigned: kats)

Tracking

({regression})

unspecified
mozilla45
All
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(firefox45 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8692558 [details]
gdb

This assertion triggers quite often on current trunk with debug gecko.
entering task manager, opening apps..
(Reporter)

Comment 1

3 years ago
kats, any ideas?
Flags: needinfo?(bugmail.mozilla)
(Reporter)

Comment 2

3 years ago
Maybe bug 1226872?
Blocks: 1226872
Keywords: regression
Hm, yeah it could be a regression from that. I'll try to repro and investigate.
Assignee: nobody → bugmail.mozilla
Flags: needinfo?(bugmail.mozilla)
OS: Unspecified → Gonk (Firefox OS)
Hardware: Unspecified → All
Component: Graphics → Layout
Created attachment 8692579 [details] [diff] [review]
Possible fix

Oh! I think I know what the problem is. Can you try the attached patch and see if it fixes it?
Attachment #8692579 - Flags: feedback?(anygregor)
Created attachment 8692593 [details] [diff] [review]
Patch

Same basic patch, but cleaned up. I'm pretty sure this will fix it.
Attachment #8692579 - Attachment is obsolete: true
Attachment #8692579 - Flags: feedback?(anygregor)
Attachment #8692593 - Flags: feedback?(anygregor)
Attachment #8692593 - Flags: review?(roc)
Thanks!
(Reporter)

Comment 8

3 years ago
Comment on attachment 8692593 [details] [diff] [review]
Patch

Seems to be fixed!
Attachment #8692593 - Flags: feedback?(anygregor) → feedback+

Comment 9

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/77e84c67b947
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
You need to log in before you can comment on or make changes to this bug.