Closed Bug 1228405 Opened 4 years ago Closed 4 years ago

[TV][Remote Control] The QR code should be selected by default after saving the new settings

Categories

(Firefox OS Graveyard :: Gaia::TV, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: cynthiatang, Assigned: lchang)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 file)

STR:
 1. Launch TV Remote Control
 2. Go to Settings
 3. Select "Pairing code - ON" and press OK
 4. Press Save 

Actual result:
 - The setting is selected.

Expected result:
 - The QR code should be selected by default
QA Whiteboard: [COM=TV::Remote Control]
Flags: needinfo?(lchang)
Assignee: nobody → lchang
Status: NEW → ASSIGNED
Flags: needinfo?(lchang)
Comment on attachment 8692749 [details] [review]
[gaia] luke-chang:1228405_tv_remote_control_qrcode_default > mozilla-b2g:master

Hi Rex,

Another patch needs your help. Thanks a lot.
Attachment #8692749 - Flags: review?(rexboy)
Comment on attachment 8692749 [details] [review]
[gaia] luke-chang:1228405_tv_remote_control_qrcode_default > mozilla-b2g:master

LGTM.
Attachment #8692749 - Flags: review?(rexboy) → review+
landed on master: https://github.com/mozilla-b2g/gaia/commit/b7c45176eee556e62153eea9b88eae9583003985
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8692749 [details] [review]
[gaia] luke-chang:1228405_tv_remote_control_qrcode_default > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): TV Remote Control feature
[User impact] if declined: UX Spec violation.
[Testing completed]: yes.
[Risk to taking this patch] (and alternatives if risky): Low. It only affects Remote Control App.
[String changes made]: N/A
Attachment #8692749 - Flags: approval-gaia-v2.5?
blocking-b2g: --- → 2.5+
Comment on attachment 8692749 [details] [review]
[gaia] luke-chang:1228405_tv_remote_control_qrcode_default > mozilla-b2g:master

Approve for TV 2.5 remote control
Attachment #8692749 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.