After terminating Firefox with Task Manager, restart does not open GUI

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
major
RESOLVED WORKSFORME
2 years ago
6 months ago

People

(Reporter: DaveLaw, Unassigned)

Tracking

({64bit})

42 Branch
x86_64
Windows 8.1
64bit
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

This bug has only been observed since installing Firefox x64.
After terminating Firefox (completely) with Task Manager, restart does not open GUI.
(Firefox does start, but it does not open a GUI)
Only solution is to reinstall Firefox, which is getting a bit boring.
(Reporter)

Updated

2 years ago
Severity: normal → major
Keywords: 64bit
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
@Reporter - I am unable to reproduce this error. Below are the steps I applied. Please provide detailed steps of the action you apply so that I may attempt to get to the root of this error. Also have you updated FF? So you have any Anti-virus for Firewall that may be causing interference?

Build ID 	20151029151421
User Agent 	Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
1) Start FF 42.0
2) Browse youtube and play a video
3) Access Task Manager and EndTask for Firefox
4) Restart Firefox from desktop icon
Results: Firefox is restored at my last place of access - youtube.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(Mozilla)
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

2 years ago
Not quite sure what you mean by have I updated Firefox: v42.0 is the latest x64 release.
Following Plugins are installed:
Firebug, Leo Dictionaries, Leo Search, McAfee Webadvisor, Mozilla Archive Format & NoScript.
Virus Scanner: AVG Free
I regularly kill Firefox to clean up because of Bug 1163440 just to retain active tabs on restart.
Unfortunately, now you also have to reinstall as the restart does not open a GUI.
(you can see it starts Firefox which remains active in the Task Manager, but no GUI is opened)
It only happens with the x64 version.
Is there a trace/console anywhere?
Flags: needinfo?(Mozilla)
@Reporter -  Clarity: yes to ensure you are using the the latest build id for Firefox 42.0 - however it appears you are sure of the version.
1) Disable Antivirus software that may interfere with the update
2) Start Firefox and access Open Menu - click the (?) located at the bottom near Customize
3) Select About Firefox and a dialog should appear - Firefox will update or report that Firefox is up to date.
Also:  have you tried the "Refresh Firefox" option? This would reset the browser to the default and remove add-on, but it would mean a fresh start.
Last:  Yes there is the Developer Tools Web Console. Here is the link for more information on that https://developer.mozilla.org/en-US/docs/Tools/Web_Console
(Reporter)

Comment 4

2 years ago
So, without a GUI there is no access to the console?
I have tried to reproduce again, and I cannot not.  I am now reopening and escalating. Thank you.
Relates to Bug 1163440 however it is diff OS and consistent vs. random occurrence.
Status: RESOLVED → REOPENED
Component: Untriaged → Graphics
Ever confirmed: true
Product: Firefox → Core
Resolution: WORKSFORME → ---

Updated

2 years ago
Whiteboard: gfx-noted

Comment 6

7 months ago
Does this still reproduce for you?

I've run 64bit nightlies on multiple Windows versions and not seen this issue.
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(Mozilla)
Whiteboard: gfx-noted → [closeme 2017-07-15][gfx-noted]
(Reporter)

Comment 7

7 months ago
No, sorry I didn't get back to you on this.
Has not happened for ages now.
No problems with Firefox at the moment.
Even the [Bug 1163440] random graphics corruption "screen turns black", which bothered me constantly and is still constantly bothering others has gone away.
Flags: needinfo?(Mozilla)

Updated

6 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago6 months ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2017-07-15][gfx-noted] → [gfx-noted]
You need to log in before you can comment on or make changes to this bug.