Convert event to message is broken (ReferenceError: "aToList is not defined" when calling getRecipientList)

RESOLVED FIXED in 4.6

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: ssitter, Assigned: MakeMyDay)

Tracking

({regression})

Lightning 4.6
Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

Lightning 4.7a1 (20151126030234) with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.0a1

Steps:
Thunderbird is setup with only one "Blogs & News Feeds" account but no email account. When right clicking on an event and selecting Convert To > Message... from context menu nothing happens. The error console shows:

> Error: ReferenceError: aToList is not defined
> Source File: resource://calendar/modules/calUtils.jsm Line: 367

It looks like the broken code was added with Bug 1158036, therefore this problem might exist in Lightning 4.2 and newer. I only tested Lightning 4.6a2 and Lightning 4.7a1.
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Posted patch FixGetRecipientList-V1.diff (obsolete) โ€” โ€” Splinter Review
Apart from the obvious fix, I add two unit tests for the used calUtils.jsm functions. The patch should be applied on top of that for bug 1212075.

A try push for tests of both bugs is still running.
Attachment #8692989 - Flags: review?(philipp)
Comment on attachment 8692989 [details] [diff] [review]
FixGetRecipientList-V1.diff

Review of attachment 8692989 [details] [diff] [review]:
-----------------------------------------------------------------

Check for whitespaces and maybe use an arrow function for the filter
Attachment #8692989 - Flags: review?(philipp) → review+
Updated patch according to the above comments.

We need this also for aurora and beta.
Attachment #8692989 - Attachment is obsolete: true
Attachment #8702893 - Flags: review+
Attachment #8702893 - Flags: approval-calendar-beta?(philipp)
Attachment #8702893 - Flags: approval-calendar-aurora?(philipp)
Attachment #8702893 - Flags: approval-calendar-beta?(philipp)
Attachment #8702893 - Flags: approval-calendar-beta+
Attachment #8702893 - Flags: approval-calendar-aurora?(philipp)
Attachment #8702893 - Flags: approval-calendar-aurora+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 4.8
Keyword "checkin-needed" set for aurora/beta
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-aurora, comm-beta]
Just to be clear, I do not routinely do comm-beta checkins for calendar bugs, but I assume that the calendar team has their own process to get these checked in.
The calendar process has usually been, whoever does the push to c-c also does the backport to approved branches.
We should either skip the beta uplift for this or also uplift bug 121075.
Whiteboard: [checkin-needed comm-aurora, comm-beta] → [checkin-needed comm-aurora]
Backported to releases/comm-aurora changeset 54de083be103
Keywords: checkin-needed
Target Milestone: 4.8 → 4.7
Backported to releases/comm-beta changeset 3866c4feab99
Target Milestone: 4.7 → 4.6
Whiteboard: [checkin-needed comm-aurora]
This broke unit tests on beta: https://treeherder.mozilla.org/logviewer.html#?job_id=5710&repo=comm-beta
TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_calutils.js | getAttendeeEmail_test - [getAttendeeEmail_test : 59] (test #1) - "first.last@example.net" == "\\"Last, First\\" <first.last@example.net>"
yes, this is expected without the uplift at least of bug 1212075, see comment #8.
Please do not add additional beta test breakages, can we get the issues of comment 11 and comment 8 resolved please?
The additional backport is already available in the other bug.
Duplicate of this bug: 1272907
You need to log in before you can comment on or make changes to this bug.