crash in libavcodec.so.56.60.100@0x207fc1 when playing video

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: illumilor.e, Unassigned)

Tracking

({crash})

42 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 2015103000

Steps to reproduce:

When playing any youtube video, when the page first loads, firefox will crash, and then a window saying firefox has crashed will show up.

Comment 1

2 years ago
Thanks for taking the time to report this!
Please follow the steps on http://support.mozilla.com/kb/Firefox%20crashes and report back here. 

Also, unfortunately this report is not very useful because it does not describe the problem well. If you have time and can still reproduce the problem, please read https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines and add a more useful description to this report.
Flags: needinfo?(illumilor.e)
(Reporter)

Comment 2

2 years ago
It is on opensuse 42.1
Flags: needinfo?(illumilor.e)

Comment 3

2 years ago
Please reproduce the crash with a build from mozilla.org, submit the crash report, then post the report ID from about:crashes in a comment here.
https://developer.mozilla.org/docs/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Flags: needinfo?(illumilor.e)
Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

2 years ago
Duplicate of this bug: 1230434

Updated

2 years ago
Duplicate of this bug: 1230434
(Reporter)

Comment 6

2 years ago
It says it submits the crash report everytime it crashes.
Flags: needinfo?(illumilor.e)

Updated

2 years ago
Duplicate of this bug: 1230434

Comment 8

2 years ago
Please reproduce the crash with a build from mozilla.org, submit the crash report, then post the report ID from about:crashes in a comment here.
https://developer.mozilla.org/docs/How_to_get_a_stacktrace_for_a_bug_report
Flags: needinfo?(illumilor.e)
(Reporter)

Comment 9

2 years ago
https://crash-stats.mozilla.com/report/index/80ab9a7c-0cd5-45d1-981b-c82a72151205#allthreads
Flags: needinfo?(illumilor.e)

Updated

2 years ago
Crash Signature: [@ libavcodec.so.56.60.100@0x207fc1 ]
Summary: firefox crashes when playing video → crash in libavcodec.so.56.60.100@0x207fc1 when playing video
Please Update -  mark as Resolved Duplicate : 1230434 or move to Core: Audio Video
Flags: needinfo?(gingerbread_man)

Comment 11

2 years ago
Bug 1230434 is probably a duplicate of this one, not the other way around. I'm not marking it as such anymore because reporter is arguing to the contrary: see bug 1230434, comment 3 and onward.

This may be resolved with the latest version of Firefox and ffmpeg.
Component: Untriaged → Audio/Video: Playback
Flags: needinfo?(gingerbread_man)
Product: Firefox → Core
The original report is using FFmpeg 42. FFmpeg isn't available in Firefox 42 unless you manually enable it.

It was disabled for a reason.

Please try again with 43.
(In reply to illumilor.e from comment #2)
> It is on opensuse 42.1

Opensuse doesn't ship with a FFmpeg build with h264 or aac decoder, it's unusable to play YouTube.

If you are using 42, disable ffmpeg ; or better upgrade to the latest official version: 43
GStreamer support has been removed so this should no longer be an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.