Closed Bug 1228513 Opened 6 years ago Closed 4 years ago

Turn on wifi and when it is searching aps, turn on "Airplane mode", the wifi will be toggled on/off alternately

Categories

(Firefox OS Graveyard :: Wifi, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:2.5?, b2g-v2.5 affected, b2g-master affected)

RESOLVED WONTFIX
blocking-b2g 2.5?
Tracking Status
b2g-v2.5 --- affected
b2g-master --- affected

People

(Reporter: liuke, Unassigned)

References

Details

(Whiteboard: [2.5-aries-test-run-4])

Attachments

(2 files)

Attached video FlameKK2.5.3gp
[1.Description]:
[Flame v2.5&master][Aries v2.5&master]Turn on wifi and when it is searching aps,  turn on "Airplane mode", the wifi will be toggled on/off alternately 
See attachment: FlameKK2.5.mp4 and logcat.txt
Found at: 1:58

[2.Testing Steps]: 
1. Launch Settings;
2. Enter the wifi screen
3. Toggle on Wifi
4. Return to previous screen and enable "Airplane mode" when the wifi is searching;

[3.Expected Result]: 
4. Aireplane mode is turned on and wifi is turned off automatically.

[4.Actual Result]: 
4. Airplane mode is turned on but wifi will be toggled on/off alternately.

[5.Reproduction build]: 
Device: Flame v2.5_512mb user:
Build ID               20151126113148
Gaia Revision          34ccc2c8f17b87a1fab95a4186b0019ec78c7f75
Gaia Date              2015-11-26 09:44:10
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fbaba398bd98fd1837ef2fd7c13ed8ee69640cfb
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.104320
Firmware Date          Thu Nov 26 10:43:29 UTC 2015
Bootloader             L1TC000118D0

Device: Flame KK master_512mb user
Build ID               20151126172432
Gaia Revision          86959c405348d27ba5686956ae3a8ffc274d3db8
Gaia Date              2015-11-26 06:53:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/74c7941a9e22d50057800771ebae07f69deecc9f
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.164303
Firmware Date          Thu Nov 26 16:43:13 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 dogfood:
Build ID               20151126113601
Gaia Revision          34ccc2c8f17b87a1fab95a4186b0019ec78c7f75
Gaia Date              2015-11-26 09:44:10
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fbaba398bd98fd1837ef2fd7c13ed8ee69640cfb
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.104443
Firmware Date          Thu Nov 26 10:44:51 UTC 2015
Bootloader             s1

Device: AriesKK master user 
Build ID               20151126173500
Gaia Revision          86959c405348d27ba5686956ae3a8ffc274d3db8
Gaia Date              2015-11-26 06:53:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/74c7941a9e22d50057800771ebae07f69deecc9f
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.165407
Firmware Date          Thu Nov 26 16:54:15 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached file logcat.txt
Hi Fred,
Could you help to check this bug? Its behavior is same with bug 1217717, just with different STR. 
Thanks :)
Flags: needinfo?(gasolin)
All of these devices that comment 0 mentioned are affected.
See Also: → 1217717
If user turns off airplane mode after Step 4, it still can't recover unless user turn off/on wifi again.
[Blocking Requested - why for this release]:
Once bug happens, it can consume power quietly on the background, and it brings bad user experience.
blocking-b2g: --- → 2.5?
QA Whiteboard: [severe]
A workaround might be disable the AirplaneMode toggle in Settings/QuickSettings when wifi is searching aps?
Any better idea?
Flags: needinfo?(tihuang)
Flags: needinfo?(hchang)
Flags: needinfo?(gasolin)
Right now, We don't have a better solution. Thus, I think that disable the AirplaneMode would be sufficient.
Flags: needinfo?(tihuang)
Clear the needinfo request because we are not actively working on FxOS now.
Flags: needinfo?(hchang)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.