[Music]The text on "Close" button disappears in music search page.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Music
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Sharon, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master unaffected)

Details

(Whiteboard: [2.5-aries-test-run-4])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Aries KK v2.5][Flame KK v2.5]When you tap the search field to search page,you will find that the text on close button disappears.

See attachment: Flame_KK_v2.5.png and logcat.txt
Found at: 15:56

[2.Testing Steps]: 
1. There are some music files on DUT.
2. Tap 'Music' from the home screen.
3. Slide down the screen to display the search field.
4. Tap the search field to search page.
5. Input some keywords.

[3.Expected Result]: 
step4. The text on close button displays normally.
step5. The text on close button displays normally.

[4.Actual Result]: 
step4. The text on close button disappears.
step5. The text on close button disappears.

[5.Reproduction build]: 
Device: Aries KK v2.5(affected)
Build ID               20151126113601
Gaia Revision          34ccc2c8f17b87a1fab95a4186b0019ec78c7f75
Gaia Date              2015-11-26 09:44:10
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fbaba398bd98fd1837ef2fd7c13ed8ee69640cfb
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.104443
Firmware Date          Thu Nov 26 10:44:51 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 512mb(affected)
Build ID               20151126113148
Gaia Revision          34ccc2c8f17b87a1fab95a4186b0019ec78c7f75
Gaia Date              2015-11-26 09:44:10
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fbaba398bd98fd1837ef2fd7c13ed8ee69640cfb
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.104320
Firmware Date          Thu Nov 26 10:43:29 UTC 2015
Bootloader             L1TC000118D0

Device: Aries KK master(unaffected)
Build ID               20151126173500
Gaia Revision          86959c405348d27ba5686956ae3a8ffc274d3db8
Gaia Date              2015-11-26 06:53:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/74c7941a9e22d50057800771ebae07f69deecc9f
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.165407
Firmware Date          Thu Nov 26 16:54:15 UTC 2015
Bootloader             s1

Device: Flame KK master 512mb(unaffected)
Build ID               20151126030209
Gaia Revision          86959c405348d27ba5686956ae3a8ffc274d3db8
Gaia Date              2015-11-26 06:53:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c321d84038519dcf1670d59fd2c5c00ad8a85a55
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151126.065552
Firmware Date          Thu Nov 26 06:56:03 EST 2015
Bootloader             L1TC000118D0

Device: Flame KK v2.2 512mb(unaffected)
Build ID               20151126032505
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/55474d171658
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151126.065633
Firmware Date          Thu Nov 26 06:56:44 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]: 
The text on close button is disappear,but the close button is worked.
(Reporter)

Comment 1

3 years ago
Created attachment 8692884 [details]
Flame_KK_v2.5.png
(Reporter)

Comment 2

3 years ago
Created attachment 8692885 [details]
logcat.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → unaffected
Keywords: regression

Updated

3 years ago
Duplicate of this bug: 1229140
Flagging Wilson for NI? since he recently updated the search bar UI.
Flags: needinfo?(wilsonpage)
Bug 1225472 needs uplifting to v2.5.
Depends on: 1225472
Flags: needinfo?(wilsonpage)
Created attachment 8701745 [details]
FlameKK2.5_screenshot.png

This problem cannot be reproduced on latest build of Aries KK 2.5 and Flame KK 2.5 by the STR in comment 0. On music search view, the "Close" button display normally and work normally now.

See attachment: FlameKK2.5_screenshot.png
Reproduce rate: 0/10

Device information:
Aries KK v2.5 (Pass)
Build ID               20151223153111
Gaia Revision          8db2cdd9eb9b42932c4dfc86d109b3e46c220809
Gaia Date              2015-12-23 13:30:29
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/6fac3536a96a87185a6415d6ae2c36a85612e863
Gecko Version          44.0
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151223.144147
Firmware Date          Wed Dec 23 14:41:54 UTC 2015
Bootloader             s1

Flame KK v2.5(512mb)(Pass)
Build ID               20151223152613
Gaia Revision          8db2cdd9eb9b42932c4dfc86d109b3e46c220809
Gaia Date              2015-12-23 13:30:29
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/6fac3536a96a87185a6415d6ae2c36a85612e863
Gecko Version          44.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151223.143931
Firmware Date          Wed Dec 23 14:39:41 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Last Resolved: 2 years ago
QA Whiteboard: [MGSEI-Triage+]
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.