Iggybook.com sends incorrect Content-Disposition header; filenames with spaces are truncated and lack extension

RESOLVED DUPLICATE of bug 221028

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 221028
2 years ago
a year ago

People

(Reporter: J-C, Unassigned)

Tracking

42 Branch

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

651.93 KB, application/epub+zip
Details
(Reporter)

Description

2 years ago
Created attachment 8692923 [details]
Trois

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

On Iggybook website, I want to download a ebook ended by .epub, using this link :
http://jerome-dumont.iggybook.com/fr/commerce/payment/download/1htrt8lwqy3o0os0wsso8sco00o8gkk/epub/ebook


Actual results:

I obtain this : a file named [Trois] 


Expected results:

I'm waiting this (downloaded with GoogleChrome) :
Trois balles dans le buffet_Rossetti & MacLane 4_Jerome-Dumont.epub

Comment 1

2 years ago
This happens because the filename in question contains spaces, but the server sends an improper Content-Disposition header. You need to contact the site owners and ask them to fix the issue. They can find technical details below:
* Bug 221028, comment 61
* http://kb.mozillazine.org/Filenames_with_spaces_are_truncated_upon_download
* http://stackoverflow.com/questions/18634337/how-to-set-filename-containing-spaces-in-content-disposition-header
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → File Handling
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Summary: No .epub by downloading ebooks → Iggybook.com sends incorrect Content-Disposition header; filenames with spaces are truncated and lack extension
Duplicate of bug: 221028
(Assignee)

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.