Closed Bug 1228674 Opened 4 years ago Closed 4 years ago

test_archive.py: error: unrecognized arguments: 45.0a1.common.tests.zip in c-c OSX opt builds

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox44 fixed, firefox45 fixed, b2g-v2.5 fixed)

RESOLVED FIXED
mozilla45
Tracking Status
firefox44 --- fixed
firefox45 --- fixed
b2g-v2.5 --- fixed

People

(Reporter: aleth, Assigned: aleth)

References

Details

(Keywords: regression, Whiteboard: [also affects comm-aurora])

Attachments

(1 file)

/builds/slave/tb-c-cen-m64-ntly-000000000000/build/objdir-tb/i386/_virtualenv/bin/python -m mozbuild.action.test_archive  common /builds/slave/tb-c-cen-m64-ntly-000000000000/build/objdir-tb/i386/dist/mac/en-US//Daily 45.0a1.common.tests.zip
 usage: test_archive.py [-h] archive outputfile
 test_archive.py: error: unrecognized arguments: 45.0a1.common.tests.zip
 make: *** [package-tests-common] Error 2
Blocks: 1208320
Keywords: regression
On Linux, this command is 
/builds/slave/tb-c-cen-l64-00000000000000000/build/objdir-tb/_virtualenv/bin/python -m mozbuild.action.test_archive  common /builds/slave/tb-c-cen-l64-00000000000000000/build/objdir-tb/dist//thunderbird-45.0a1.en-US.linux-x86_64.common.tests.zip

I assume the reason there is a "Daily " on OSX Opt must have something to do with universal builds...
Naive fix
Attachment #8693096 - Flags: review?(gps)
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Whiteboard: [also affects comm-aurora]
Attachment #8693096 - Flags: review?(gps) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/de171af8720b687c75e5ea5b5de4030a6da98043
Bug 1228674 - Handle filenames with spaces in 'define package_archive'. r=gps
https://hg.mozilla.org/mozilla-central/rev/de171af8720b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Comment on attachment 8693096 [details] [diff] [review]
Handle filenames with spaces in 'define package_archive'

Approval Request Comment
[Feature/regressing bug #]: 1208320 (mozilla 44)
[User impact if declined]: c-c OSX opt build issue
[Risks and why]: low risk
Attachment #8693096 - Flags: approval-mozilla-aurora?
Gregory, do you think it's safe to uplift this to Aurora44? I didn't see a comment on test coverage in the patch uplift request so I wanted to get your opinion.
Flags: needinfo?(gps)
It's a safe patch to uplift. Either the build works or it doesn't.
Flags: needinfo?(gps)
Comment on attachment 8693096 [details] [diff] [review]
Handle filenames with spaces in 'define package_archive'

GPS said this one is safe to uplift to Aurora44.
Attachment #8693096 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.