After closing a pinned page, homescreen opens the wrong app when clicking on any icon from the main screen

RESOLVED DUPLICATE of bug 1227789

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1227789
3 years ago
3 years ago

People

(Reporter: Mihai Barbat, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151128030230

Steps to reproduce:

I am using OTA 20151128150206 on a Flame phone
Using the new homescreen, open a pinned page.
Long press on the home button to see your running pinned page.
Close the pinned page you just opened.
Switch to the 1-st (main) view on the homescreen where all the apps and pinned sites are.
Open Marketplace.
Instead of Marketplace, either the previous pinned page reopens or another app from the main screen
(Reporter)

Comment 1

3 years ago
Here is a movie I made with the issue: https://www.youtube.com/watch?v=Cva_6hNj5ng
(Reporter)

Updated

3 years ago
Summary: After closing a pinned page homescreen reopens it when clicking on any icon from the main screen → After closing a pinned page, homescreen opens the wrong app when clicking on any icon from the main screen
(Reporter)

Updated

3 years ago
Keywords: foxfood
Whiteboard: [systemsfe]

Comment 2

3 years ago
I cannot reproduce with 20151129 build in Flame
(Reporter)

Comment 3

3 years ago
Just tried it again with OTA 20151130030223 build on the Flame and I can reproduce it. 

You need to immediately switch to the main screen after closing the pinned page and click on a app or pinned site. The wrong app starts or the previous opened page.

If you need I can upload another clip.

Comment 4

3 years ago
I have the same build now. I can reproduce the bug.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1227789
You need to log in before you can comment on or make changes to this bug.