Closed Bug 1228820 Opened 4 years ago Closed 4 years ago

Screen switches after closing pinned page

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: mihaibn, Unassigned)

References

Details

(Keywords: foxfood, Whiteboard: [systemsfe])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151128030230

Steps to reproduce:

I am using OTA 20151128150206 on a Flame phone

Using the new homescreen, open a pinned page.
Long press on the home button to see your running pinned page.
Close the pinned page you just opened.
Immediately swipe on your screen to move to the main screen where the apps and the pinned sites are.
You will notice that the screen switches back and forth between the 1-st and 2-nd screen where pinned pages are.
here is a movie I made with the issue: https://www.youtube.com/watch?v=ErI_HgiEa5E
Keywords: foxfood
I believe thats a dup that should be fixed by now. Chris any idea?
Flags: needinfo?(chrislord.net)
Whiteboard: [systemsfe]
I cannot reproduce with 20151129 build in Flame
I could reproduce it again with OTA 20151130030223 build on the Flame!
You need to immediately switch to the main screen after closing the pinned page.
I think this is a side-effect of snapping being done on the content thread (so a platform issue) - tracked in bug 1219296.
Depends on: 1219296
Flags: needinfo?(chrislord.net)
I'm not convinced about comment 5. It looks similar to bug 1227789 to me. Can we check if it happens in the 20151124190915 Flame 2.5 build (the "working" build from bug 1227789 comment 1)?
Flags: needinfo?(mihaibn)
I don't have access to that build anymore or have means to flash it unfortunately :( Someone else?
Any other recent Flame 2.5 build should be ok as well, since if this *is* a regression from bug 1222524 it shouldn't affect 2.5 builds.
I can only update to the next OTA, maybe others here can test with the old version.
Flags: needinfo?(mihaibn)
Status: UNCONFIRMED → NEW
Ever confirmed: true
this became much harder to reproduce since https://bugzilla.mozilla.org/show_bug.cgi?id=1234176 was fixed.

It feels like the touch action is not registered anymore immediately after you close the pinned page. Nevertheless when you catch the side of the screen to swipe back to the 1-st page of the homescreen immediately after closing a pinned page, the screen still bounces around.
Significant improvements have been made to scroll snapping in bug 1219296, which may have fixed part of all of the underlying issue of this bug. The specific STR here are B2G-specific, so I'm going to close this bug as WONTFIX for now.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.