If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

BrightCove player serves Flash to Firefox and <video> to Chromium

RESOLVED INVALID

Status

Tech Evangelism
Desktop
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: julienw, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [lib-brightcove][country-all][platform-rel-Brightcove] [needsdiagnosis], URL)

(Reporter)

Description

2 years ago
With this URL: http://www.programme.tv/news/actu/149327-excellent-yann-moix-laurent-delahousse-lorant-deutsch-parodies-par-marc-antoine-le-bret-videos/

I can see that on Firefox I get the Flash version that is really slow on Xorg with intel drivers, but on Chromium I get the HTML5 version that is really smooth.

Even disabling Flash in Firefox, I get the message "you need to update Flash".
Spoofing as Fx Android on desktop, I see Fx requests an mp4 file like 
http://videos.prismamediadigital.com/media/800000640001/201511/3766/800000640001_4636418578001_4636277680001.mp4?playerId=1768765287001&lineupId=&affiliateId=&pubId=800000640001&videoId=4636277680001
It starts appearing, but after less than a second it disappears and the VIDEO element says "Cette vidéo is momentanemént indisponible" in white on a black background. Loading the URL directly plays the video just fine. This needs more diagnosis.
(Reporter)

Comment 2

2 years ago
I noticed that I can pass "?forceHTML=true" as parameter to the page, which forces HTML5 mode.

I also notice the website loads the scripts directly from brightcove's website. However everything seems to work fine for videos from their websites (ex: https://support.brightcove.com/en/video-cloud/training-videos/brightcove-smart-players)
(Just for the record, there is an "old" and a "new" Brightcove player, the new one works pretty well and the old one tends to complain about missing Flash if it doesn't like your user-agent - unfortunately many of their customers are still using the old one.. see https://bugzilla.mozilla.org/show_bug.cgi?id=brightcove This bug as reported is likely a dup of that but I'd like to know what causes the "indisponible" error I'm seeing..)
(Reporter)

Comment 4

2 years ago
My very wild guess is that somewhere there is a bad check for whether you're in the right country.
I did some testing and don't believe it's a regional error.

Hallvord, do you want to continue testing this? Or should we start looking for a contact and ask them to update?
Flags: needinfo?(hsteen)
Whiteboard: [lib-brightcove][country-all]
Sorry to have left this hanging..

There's a console error saying "Invalid URI. Load of media resource  failed.". But that's weird, because it loads about 12M of video data - not exactly evidence of an invalid URL.
Flags: needinfo?(hsteen)
So, there's one desktop issue (it says "update Flash" even if Flash is disabled, doesn't automatically use HTML5 video) and one Android issue (playback fails with an error). The desktop issue is well understood, this is how the old Brightcove version works - defaulting to Flash even in Firefox versions that support the VIDEO element. The site should consider updating to the new Brighcove script.

The issue on Android is not understood yet. I might split that off into a separate bug.
(Reporter)

Comment 8

a year ago
I just contacted them through Twitter but I doubt this will really get to them.
The invalid URL error happens when .src is set to null. This might happen in response to some unexpected error firing..? Still digging into the Android problem here.
platform-rel: --- → ?
Whiteboard: [lib-brightcove][country-all] → [lib-brightcove][country-all][platform-rel-Brightcove]
So going there 
http://www.programme.tv/news/actu/149327-excellent-yann-moix-laurent-delahousse-lorant-deutsch-parodies-par-marc-antoine-le-bret-videos/

with Gecko Desktop + Chrome UA, I get the same flash player request.

I also get the request for the flash plugin in Opera/Blink


Are we sure that issue?
Whiteboard: [lib-brightcove][country-all][platform-rel-Brightcove] → [lib-brightcove][country-all][platform-rel-Brightcove] [needsdiagnosis]
(Reporter)

Comment 11

a year ago
Actually I agree with you I also get the Flash player on my Chromium. I don't know what made me believe this in comment 0, maybe they changed something (I doubt it though)?
Karl - we now have a ML with Brightcove. Feel free to use for outreach if appropriate.
ok I will close as invalid and we can reopen if we have a clear way to reproduce and highlight the differences if any. Thanks.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.