Undefined entity safeb.blocked.forbiddenPage.title

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: sebastian, Assigned: Margaret)

Tracking

({regressionwindow-wanted})

unspecified
All
Android
regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(fennec45+)

Details

STR:
* Go to http://www.itisatrap.org/firefox/its-an-attack.html

Expected:
* "Reported Attack" page should show up

Actual:
* Error about undefined entity (&safeb.blocked.forbiddenPage.title;) is shown
tracking-fennec: --- → ?
Margaret, can you find an assignee?
Assignee: nobody → margaret.leibovic
Blocks: 1227800
tracking-fennec: ? → 45+
Keywords: regressionwindow-wanted
Works for me. Sebastian, is this a localized build?
Flags: needinfo?(s.kaspari)
Should be fixed in bug 1227800 but could happen again since we don't have any Safe Browsing UI tests on Fennec :(
(In reply to François Marier [:francois] from comment #4)
> Should be fixed in bug 1227800 

That landed the 26th, but this was reported the 30th.

> but could happen again since we don't have any Safe Browsing UI tests on Fennec :(

Why don the normal mochitests not cover the Android error pages?
Yikes, Nightly was lagging behind on this device. With the latest version the issue is gone.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(s.kaspari)
Resolution: --- → INVALID
(Assignee)

Comment 7

2 years ago
(In reply to Gian-Carlo Pascutto [:gcp] from comment #5)
> (In reply to François Marier [:francois] from comment #4)
> > Should be fixed in bug 1227800 
> 
> That landed the 26th, but this was reported the 30th.
> 
> > but could happen again since we don't have any Safe Browsing UI tests on Fennec :(
> 
> Why don the normal mochitests not cover the Android error pages?

These tests likely don't run on Android. If we have a forked version of the page, we probably need the tests to be slightly different, so it might not be as easy as just enabling the tests.

But we should look into getting some of these tests to run on Android. Here are docs about mochitest on Android:

https://wiki.mozilla.org/Mobile/Fennec/Android/Testing#mochitest_.28plain_and_chrome.29
You need to log in before you can comment on or make changes to this bug.