Music search UI is missing the 'close' button on v2.5

RESOLVED DUPLICATE of bug 1228535

Status

RESOLVED DUPLICATE of bug 1228535
3 years ago
3 years ago

People

(Reporter: pcheng, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master unaffected)

Details

(Whiteboard: [2.6-Daily-Testing] [spark])

Attachments

(3 attachments)

Created attachment 8693753 [details]
screenshot of issue on 2.5

Description:
The new search UI in Music is missing the 'close' button in the search panel, causing a serious UI flow issue - user is unable to return to normal Music view in this panel unless they actually searches for something and tap on the search result.

STR:
1) Flash to a 2.5 build that has new Music search UI
2) Open Music app
3) Swipe down to reveal the search bar
4) Tap on the bar to enter search panel

Expected: A 'close' button exists to the right of search bar (2.6 does this)

Actual: No 'close' button on search bar. User cannot close out of this panel unless they search something and tap on the search result.

See screenshot for issue.

Repro rate: 5/5

Bug occurs on:
Device: Flame 2.5
BuildID: 20151130173516
Gaia: 391bcad1b3b427f189f4c7f11858fc739574682e
Gecko: 1a022b4b67446b50f36c098aa425c65782af9066
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Aries 2.5
BuildID: 20151130171620
Gaia: 391bcad1b3b427f189f4c7f11858fc739574682e
Gecko: 1a022b4b67446b50f36c098aa425c65782af9066
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
(Reporter)

Comment 1

3 years ago
Created attachment 8693756 [details]
logcat of issue
(Reporter)

Comment 2

3 years ago
Created attachment 8693758 [details]
screenshot of expected behavior (2.6)
(Reporter)

Comment 3

3 years ago
Aries 2.6 and Flame 2.6 are unaffected. See comment 2 screenshot. The new Music search UI is not in 2.2 so not checking 2.2 for this.

Device: Flame 2.6
BuildID: 20151130030223
Gaia: ee6d8625c9d76de2f6614c87bb82b301bc37c7a9
Gecko: 47b49b0d32360fab04b11ff9120970979c426911
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Aries 2.6
BuildID: 20151130134106
Gaia: 702773bee0b70e479ccebe5e061f571e977bc376
Gecko: a18630f9ab42ddfde03ba8c7757a42069c48c7ed
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.5: --- → affected
status-b2g-master: --- → unaffected
Flags: needinfo?(jmercado)
Whiteboard: [2.6-Daily-Testing] [spark]
(Reporter)

Comment 4

3 years ago
Just realized that this is a dupe of bug 1228535.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1228535
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.