[e10s] The part of Flash content placed under the Status bar becomes transparent when Statusbar disappears

RESOLVED DUPLICATE of bug 1229455

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 1229455
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox45 affected)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

2 years ago
Created attachment 8693782 [details]
testcase 1 of 2 (flash) - Status bar box becomes transparent.htm

>>>   My Info:   Win7_64, Nightly 45, 32bit, ID 20151127030231
STR:
1. Open "testcase 1 of 2 (flash)"      in a new tab
2. Open "testcase 2 of 2 (status bar)" in a new tab next to the tab opened in Step 1.
3. Switch to the tab with "testcase 2 of 2"
4. Wait about 3 seconds (in order not to experience another bug)
5. Hover mouse over the "Sample link"   [make sure there's a relatively long tooltip at the bottom]
6. Switch to the tab opened in Step 2.

Result:       
 The status bar blinks (first disappears, but then quickly appears-disappears) during the tab switch
 Bottom part of the flash plugin is cut off. It's also reproducible with "position:static" if
 you scroll the page so that Flash was placed under the status bar.

Expectations: 
 Status bar should just disappear. Flash shouldn't be cut off.
(Reporter)

Comment 1

2 years ago
Created attachment 8693786 [details]
testcase 2 of 2 (status bar) - Status bar box becomes transparent.htm
(Reporter)

Comment 2

2 years ago
Created attachment 8693787 [details]
screenshot - Status bar box becomes transparent.png
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
I am unable to reproduce on Mac.
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Comment 7

2 years ago
STR_2 (just read it)
 1. Open "testcase 1 of 2 (flash)" in a new tab
 2. Press Ctrl+Shift+R to refresh tab w/o using cache.
Result:
 Sometimes the message "Transferring data from bugzilla.mozilla.org" is displayed in status bar,
 and sometimes it clips a part of Flash content   (the same result as in STR in comment 0)


I actually tried to create a page with both flash content and a link, but it appears that the status bar is placed _under_ the flash content. When it's placed above the flash content, I encounter this bug. Filed bug 1229455 about that weird case
See Also: → bug 1229455
Summary: [e10s] Status bar blinks during tab switch and its box becomes transparent if placed above flash content → [e10s] The part of Flash content placed under the Status bar becomes transparent when Statusbar disappears

Updated

2 years ago
tracking-e10s: --- → +

Comment 8

2 years ago
I think this might have something to do with the way the compositor currently waits on confirmation for plugin window updates from CompositorChild. It should wait on a sequence number here [1] vs. a boolean. I'm guessing with the rapid tab switching this triggers that flag is getting out of sync.

[1] http://mxr.mozilla.org/mozilla-central/search?string=mPluginUpdateResponsePending
Blocks: 874016

Comment 9

2 years ago
(In reply to Jim Mathies [:jimm] from comment #8)
> I think this might have something to do with the way the compositor
> currently waits on confirmation for plugin window updates from
> CompositorChild. It should wait on a sequence number here [1] vs. a boolean.
> I'm guessing with the rapid tab switching this triggers that flag is getting
> out of sync.
> 
> [1]
> http://mxr.mozilla.org/mozilla-central/
> search?string=mPluginUpdateResponsePending

^ crap, wrong bug. ignore.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1229455

Updated

2 years ago
No longer blocks: 874016
tracking-e10s: + → ---
You need to log in before you can comment on or make changes to this bug.