Closed Bug 1229216 Opened 4 years ago Closed 2 years ago

Possibly make Fennec's Firefox Account web flow default to /signin rather than /signup

Categories

(Firefox for Android :: Firefox Accounts, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox45 --- affected
firefox55 --- verified

People

(Reporter: nalexander, Assigned: Grisha)

References

Details

Attachments

(1 file)

There's a belief that mobile devices tend to sign in to an existing account more often than they sign up for an account.  (We certainly have data confirming this on Firefox for iOS -- the ratio was roughly 4:1, signin:signup.)  Let's validate that assumption on Fennec and change our default.

The code here is easy: just replace "signup" with "signin" around https://dxr.mozilla.org/mozilla-central/source/mobile/android/base/fxa/activities/FxAccountGetStartedActivityWeb.java#9.
(In reply to Nick Alexander :nalexander from comment #0)
> There's a belief that mobile devices tend to sign in to an existing account
> more often than they sign up for an account.  (We certainly have data
> confirming this on Firefox for iOS -- the ratio was roughly 4:1,
> signin:signup.)  Let's validate that assumption on Fennec and change our
> default.

rfkelly: can you produce this data (ratio is good, no hard numbers required) or delegate to a producer?  Thanks!
Flags: needinfo?(rfkelly)
The ratio is about 4:1 in favor of login, according to Kibana.
Flags: needinfo?(rfkelly)
Sorry, that's for iOS. For Android, the reverse is true: successful creates outnumber successful logins almost 3:1.

That might be because users go through the create flow when they log in; the link to log in is usually below the fold.
Thanks Richard; fwiw my interpretation of kibana data matches with yours

> That might be because users go through the create flow when they log in;
> the link to log in is usually below the fold.

You can't double-create on an existing account though; users might attempt to create, fail because it already exists, then visit the signin page, but this would still should up in the kibana stats as /account/login rather than /account/create
Duplicate of this bug: 1371723
Assignee: nobody → gkruglov
Status: NEW → ASSIGNED
Comment on attachment 8876247 [details]
Bug 1229216 - Make Firefox Accounts "sign-in" flow default to sign-in, not registration

https://reviewboard.mozilla.org/r/147696/#review151986

If it works for you locally, it makes sense to me!
Attachment #8876247 - Flags: review?(nalexander) → review+
Pushed by gkruglov@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/584c3716e963
Make Firefox Accounts "sign-in" flow default to sign-in, not registration r=nalexander
Change isn't risky (and easy to back-out) and not controversial. Landing it for 55.
https://hg.mozilla.org/mozilla-central/rev/584c3716e963
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Verified as fixed on Nightly 55.0a1 (2017-06-12). 
Devices:
-Prestigio Grace X5 (Android 4.4.2)
-Nexus 5 (Android 6.0.1)
-Huawei MediaPad M2 (Android 5.1.1)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.