squaresoft.com browser crashes @ various times

VERIFIED WORKSFORME

Status

()

Core
Plug-ins
--
critical
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Thomas Buffington Jr., Assigned: av (gone))

Tracking

({crash, hang})

Trunk
x86
All
crash, hang
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: talkback, URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.8+)
Gecko/20020130
BuildID:    2002013003

While on Squaresoft's official website, using Mozilla build 2002013003 which is
version 0.9.8+ with the 2002 home updated version of Windows XP I clicked on the
Squaresoft icon which brings up various choices so I clicked on games. I was
transfered to the page http://www.squaresoft.com/web/games/index.html which
displays a list of games to the left. In this case I chose Final Fantasy
Tactics. The list of games appears to the left after you choose games. 

The first thing I noticed was the site wasn't displaying any of the graphics of
Final Fantasy tactics except for the three icons at the bottom. Now this site
runs heavily on flash & shockwave both of which I have the latest versions of. I
tried refreshing the page and Mozilla crashed on me. 

The second time again I refreshed and the same thing happened. The 3rd and final
time I clicked on characters but nothing showed up it was then that I hit the
back arrow key + the browser crashed on me. I have included the three talk back
incidents in the appropriate section.

Reproducible: Always
Steps to Reproduce:
1. Goto Squaresoft.com
2. click on the Squaresoft icon at the bottom that will take you to
http://www.squaresoft.com/web/games/index.html
3. Click on "games" then click on one of the games listed to the left

These are the talk backincident reports that contain info about the three crashes.

TB2370066Z
TB2370042Y
TB2369985K

Comment 1

16 years ago
2002013103/WinNT4 -> hang after reloading Final Fantasy Tactics page
Key: +crash, +hang
Keywords: crash, hang

Comment 2

16 years ago
with a current CVS, Linux, a small window titled "Welcome to Shockwave!" popped
up saying "You're getting the free shockwave player" - then a crash.

(no crash with branch 0.9.8 where the popup simply vanishes again after a few
seconds, but plugin area remained white. Likely an unrelated linux quirk with
the shockwave plugin)

backtrace trom trunk cvs:
(gdb) bt
#0  0x40553090 in chunk_free (ar_ptr=0x40606b80, p=0x8858db8) at malloc.c:3231
#1  0x40552ff4 in __libc_free (mem=0x8858dc0) at malloc.c:3154
#2  0x401d433d in PR_Free () from libnspr4.so
#3  0x40170420 in nsMemoryImpl::Free () from libxpcom.so
#4  0x4019d7cd in nsMemory::Free () from libxpcom.so
#5  0x4014ecdd in nsStringInputStream::~nsStringInputStream () from libxpcom.so
#6  0x4014e5bd in BasicStringImpl::Release () from libxpcom.so
#7  0x4014eeec in nsStringInputStream::Release () from libxpcom.so
#8  0x4019d59f in nsCOMPtr_base::~nsCOMPtr_base () from libxpcom.so
#9  0x408424cf in nsHttpChannel::~nsHttpChannel () from libnecko.so
#10 0x408472a4 in nsHttpChannel::Release () from libnecko.so
#11 0x4019d59f in nsCOMPtr_base::~nsCOMPtr_base () from libxpcom.so
#12 0x40840c33 in nsHttpTransaction::~nsHttpTransaction () from libnecko.so
#13 0x408418df in nsHttpTransaction::DeleteSelfOnConsumerThread () from /libnecko.so
#14 0x40841a17 in nsHttpTransaction::Release () from libnecko.so
#15 0x4019d59f in nsCOMPtr_base::~nsCOMPtr_base () from libxpcom.so
#16 0x4085d79a in nsOnStopRequestEvent::~nsOnStopRequestEvent () from libnecko.so
#17 0x4080a001 in nsARequestObserverEvent::DestroyPLEvent () from libnecko.so
#18 0x40167f1a in PL_DestroyEvent () from libxpcom.so
#19 0x40167edd in PL_HandleEvent () from libxpcom.so
#20 0x40167d99 in PL_ProcessPendingEvents () from libxpcom.so
#21 0x40168de3 in nsEventQueueImpl::ProcessPendingEvents () from libxpcom.so
#22 0x4071d4e6 in event_processor_callback () from libwidget_gtk.so
#23 0x4071d248 in our_gdk_io_invoke () from libwidget_gtk.so
#24 0x4038ea7a in g_io_unix_dispatch (source_data=0x822e2d8,
current_time=0xbfffd680, user_data=0x822e2b0)
    at giounix.c:137
#25 0x40390055 in g_main_dispatch (dispatch_time=0xbfffd680) at gmain.c:656
#26 0x40390659 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#27 0x403907e8 in g_main_run (loop=0x822e350) at gmain.c:935
#28 0x402a465b in gtk_main () at gtkmain.c:524
#29 0x4071d9c5 in nsAppShell::Run () from libwidget_gtk.so
#30 0x406fe106 in nsAppShellService::Run () from libnsappshell.so
#31 0x08051b5b in main1 ()
#32 0x08052465 in main ()
#33 0x404ee627 in __libc_start_main (main=0x805232c <main>, argc=1,
ubp_av=0xbfffda84, 
    init=0x804ca4c <_init>, fini=0x8053a78 <_fini>, rtld_fini=0x4000dcc4
<_dl_fini>, stack_end=0xbfffda7c)
---Type <return> to continue, or q <return> to quit---
    at ../sysdeps/generic/libc-start.c:129
OS: Windows XP → All

Comment 3

16 years ago
->plugins
Assignee: asa → av
Status: UNCONFIRMED → NEW
Component: Browser-General → Plug-ins
Ever confirmed: true
QA Contact: doronr → shrir
Whiteboard: talkback

Comment 4

16 years ago
works ok on windows(0211 trunk). I have completely installed shockwave ( initial 
installation and registration after browser restart). reporter, can u pls try a 
recent build? 
(Reporter)

Comment 5

16 years ago
Using build ID 2002021303 version 0.9.8+ with the 2002 home updated version of 
Windows XP it seems the problems isn't occuring anymore. I'm wondering though 
what the problem was? I had the most updated versions of shockwave & flash when 
they occured but now the flash and shockwave display everything no crashes or 
hangs to report.

Comment 6

16 years ago
maybe..related the the fix serge checked in forthe  shockwave crasher 4-5 days 
ago..i was guessing that. anyway, marking this wfm since this is working for 
reporter.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.