[Settings]At Battery view, the string "Current Level" partly overlaps with by "XX% (charging)".

RESOLVED DUPLICATE of bug 1179425

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1179425
2 years ago
2 years ago

People

(Reporter: helen(leave from Mozilla), Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-v2.5 affected, b2g-master verified)

Details

(Whiteboard: LocRun2.5)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8694036 [details]
Battery_Affected.png

[1.Description]:
[Flame v2.2 & v2.5&master][Settings] At Battery view of Settings app, the string "Current Level" partly overlaps with "XX% (charging)".

See Attachment: Battery_Affected.png

[2.Testing Steps]: 
Precondition: Charging the device.
1. Set your phone language as Songhay.
2. Launch Settings -> Battery.

[3.Expected Result]: 
2.At Battery view, the string "Current Level" and "XX% (charging)"should be displayed normally.

[4.Actual Result]: 
2.At Battery view, the string "Current Level" partly overlaps with "XX% (charging)".

[5.Reproduction build]: 
Device: Flame KK master 512mb( Affected )
Build ID               20151130150225
Gaia Revision          702773bee0b70e479ccebe5e061f571e977bc376
Gaia Date              2015-11-30 02:51:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a18630f9ab42ddfde03ba8c7757a42069c48c7ed
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151130.184049
Firmware Date          Mon Nov 30 18:40:59 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.5 512mb( Affected )
Flame KK v2.5 user build
Build ID               20151130173516
Gaia Revision          391bcad1b3b427f189f4c7f11858fc739574682e
Gaia Date              2015-11-30 15:51:31
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/1a022b4b67446b50f36c098aa425c65782af9066
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151130.164630
Firmware Date          Mon Nov 30 16:46:40 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0


Device: Flame KK v2.2 512mb( Affected )
Flame KK v2.2 user build
Build ID               20151130032503
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4381c4b69b9c
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151130.071422
Firmware Date          Mon Nov 30 07:14:34 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test

[8.Note]:
1.This issue does NOT exist in, Czech, Spanish, Serbian Cyrillic, Dutch,Romanian, Portuguese from Brazil, Portuguese from Portugal, Swedish, Japanese, Traditional Chinese, Bengali from Bangladesh, Bengali from India, Slovak, Slovenian, Albanian,Bosnian, Basque, Persian.
2.This issue also exists in Urdu, and exists at Flame v2.5 &master in Arabic.
(Reporter)

Updated

2 years ago
QA Whiteboard: [MGSEI-l10n-2F]
status-b2g-v2.2: --- → affected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Helen: since there are "only" 3 locales affected so far, please open up 3 individual bugs for each language under Mozilla Localizations section, and add them here as "See Also".
Let's keep this one open while we see in the other bugs if localizers can find a work around. thanks
Flags: needinfo?(hedan)
(Reporter)

Comment 2

2 years ago
Hi Delphine,
I have opened up 3 individual bugs for each language under Mozilla Localizations section.
QA Whiteboard: [MGSEI-l10n-2F] → [MGSEI-l10n-2F][MGSEI-Triage+]
Flags: needinfo?(hedan) → needinfo?(lebedel.delphine)
Depends on: 1229675
Depends on: 1229674
Depends on: 1229676
Moving the ni on Patryk to here since this affects multiple locales and in some cases (like Arabic) seems like a regression from 2.2. THanks!
Flags: needinfo?(lebedel.delphine) → needinfo?(padamczyk)
The "charging" string seems redundant. The user already knows the battery is charging based on the battery icon having a lightning bolt. So I would remove the "charging string", it may be useful if we had an estimated time till full charge, but that would a new feature.
Flags: needinfo?(padamczyk)
(In reply to Patryk Adamczyk [:patryk] UX from comment #4)
> The "charging" string seems redundant. The user already knows the battery is
> charging based on the battery icon having a lightning bolt. So I would
> remove the "charging string", it may be useful if we had an estimated time
> till full charge, but that would a new feature.

This has been added yesterday, check out bug 1179425, the UX has changed significantly. I don’t think this bug is affects master anymore.
Helen: as per comment 5, can you please verify this on master? thanks
Flags: needinfo?(hedan)
(Reporter)

Comment 7

2 years ago
Created attachment 8696402 [details]
Battery_Verified.png

Hi Delphine,
The UX has changed on latest build of FlameKK master build, the "charging string" has been removed. It displays "xx minutes utill full charged" after charging a few minutes, and there is no overlap anymore in any Languages.

See attachment: Battery_Verified.png

Reproduce rate: 0/10

Device: Flame KK master 512mb( Pass )
Build ID               20151206150208
Gaia Revision          b930e25e9f2e5ec2106dd31005468575cdf87d50
Gaia Date              2015-12-05 03:41:55
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151206.182655
Firmware Date          Sun Dec  6 18:27:07 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Flags: needinfo?(hedan) → needinfo?(lebedel.delphine)
(Reporter)

Updated

2 years ago
status-b2g-master: affected → verified
Ok great! Closing bug then as per comment 7. thanks!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(lebedel.delphine)
Resolution: --- → DUPLICATE
Duplicate of bug: 1179425
You need to log in before you can comment on or make changes to this bug.